Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 76910 - TZ variable setting lost
Summary: TZ variable setting lost
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: glibc
Version: 8.0
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jakub Jelinek
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-10-29 10:25 UTC by Need Real Name
Modified: 2008-05-01 15:38 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2002-11-04 20:23:35 UTC


Attachments (Terms of Use)

Description Need Real Name 2002-10-29 10:25:58 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; WinNT4.0; en-US; rv:1.1) Gecko/20020826

Description of problem:
When you set and export the TZ variable, it is lost upon su and this causes
problems also with subprocesses not inheriting the value of TZ set  by the parent.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.   Set and export the TZ variable.
2.   Su to another user
3.   TZ is now set to null again.
	

Actual Results:  The TZ variable has no value again.

Expected Results:  The TZ variable should still have the value it was set to.

Additional info:

I am not sure if I have filed this bug against the correct component, but I have
as yet been unable to determine the most appropriate component responsible for
this behaviour. This problem was NOT present on versions of RH 6.x. The problem
IS present on RH 7.3 and 8.0, but I do not have 7.1/7.2 present to test on.

Comment 1 Jakub Jelinek 2002-10-29 10:43:16 UTC
There was a bug in ld.so suid/sgid unsetenv, should be fixed in
ftp://people.redhat.com/jakub/glibc/errata/7.3/ and
ftp://people.redhat.com/jakub/glibc/2.3.1-2/

Comment 2 Andrew Rechenberg 2002-11-04 20:23:29 UTC
Are the RPMS listed above stable and tested?  I am having the same issues on 
7.3 and need to get a fix in place ASAP due to time-sensitive issues, but want 
to make sure these are OK to put on a production system.

Thanks for your help,
Andy.

Comment 3 Jakub Jelinek 2002-12-03 23:19:03 UTC
The rpms have been released as errata for 7.3 and earlier, for 8.0 fixed
glibc-2.3.1-6 is in rawhide.


Note You need to log in before you can comment on or make changes to this bug.