Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 76909 - rpm gives obscure error messages on athlon computers
Summary: rpm gives obscure error messages on athlon computers
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: rpm
Version: 8.0
Hardware: athlon
OS: Linux
medium
low
Target Milestone: ---
Assignee: Jeff Johnson
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-10-29 09:24 UTC by Vidar Langseid
Modified: 2008-05-01 15:38 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2002-11-01 14:20:33 UTC


Attachments (Terms of Use)

Description Vidar Langseid 2002-10-29 09:24:48 UTC
Description of Problem:
Looks like rpm gives obscure errormessages when trying
to install a corrupted rpm on athlon systems

Try the following on pentium 4 computers:
[root@localhost root]# echo "" > foobar.rpm
[root@localhost root]# rpm -i foobar.rpm
error: foobar.rpm cannot be installed


However, when do the same on a athlon system you get this 
cryptic message:
[root@localhost root]# echo "" > foobar.rpm
[root@localhost root]# rpm -i foobar.rpm
foobar.rpm: read manifest failed: Success

I experienced this when I downloaded your updates from one (faulty) mirrorsite


Version-Release number of selected component (if applicable):


How Reproducible:
always

Comment 1 Jeff Johnson 2002-11-01 14:20:26 UTC
FWIW, the code path traveled does not
need or use arch, so the "athlon" information
is a red herring.

What version of rpm? Same on both platforms?

Comment 2 Jeff Johnson 2002-11-16 20:07:11 UTC
Closed for lack of input.


Note You need to log in before you can comment on or make changes to this bug.