Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 76907 - Track combo box paint wrong
Summary: Track combo box paint wrong
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: gtk2
Version: 8.0
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Owen Taylor
QA Contact: Jay Turner
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-10-29 04:34 UTC by Nitin Dahyabhai
Modified: 2015-01-08 00:01 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2002-11-04 21:55:20 UTC


Attachments (Terms of Use)
Sample of painting problem (deleted)
2002-10-29 04:40 UTC, Nitin Dahyabhai
no flags Details

Description Nitin Dahyabhai 2002-10-29 04:34:30 UTC
Description of Problem:
The track list combo box in gnome-cd shows the current track name at the
vertical position of the combo box.  It makes the opened combo take the entire
vertical height of the display and arranges the remaining tracks around the
current track.

Version-Release number of selected component (if applicable):
gnome-media-2.0.0-9

How Reproducible:
Always, regardless if the track list scrolls off screen or not.

Using the default GNOME environment on 8.0.

Comment 1 Nitin Dahyabhai 2002-10-29 04:40:54 UTC
Created attachment 82506 [details]
Sample of painting problem

Comment 2 Havoc Pennington 2002-11-04 21:55:12 UTC
I think it does that on purpose, but it may have changed, there was a
bugzilla.gnome.org 
bug report about it.

Comment 3 Owen Taylor 2002-11-04 22:11:53 UTC
That's an option menu not a combo box. :-)

And yes, that's the correct intended behavior.


Comment 4 Nitin Dahyabhai 2002-11-14 23:01:19 UTC
Could you point me at the bugzilla entry?  I can't find it and if the option
menu's supposed to occupy the entire screen height, I don't see why it's not
*using* the full height to begin with.  The CD in the screenshot had 49 tracks
on it and my guess is that closer to 40 could have been shown on open.

Comment 5 Owen Taylor 2002-11-15 00:08:50 UTC
The reason it isn't using the full height _initially_ is that the menu needs
to pop up with the currently selected value under the cursor.

The most relevant bugzilla.gnome.org  bug report 
is probably http://bugzilla.gnome.org/show_bug.cgi?id=72695



Note You need to log in before you can comment on or make changes to this bug.