Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 76893 - gnome-libs contains libdb1 and libdb2, please seperate
Summary: gnome-libs contains libdb1 and libdb2, please seperate
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: net-snmp
Version: 8.0
Hardware: i386
OS: Linux
medium
low
Target Milestone: ---
Assignee: Phil Knirsch
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-10-28 20:35 UTC by jbowman
Modified: 2015-03-05 01:11 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2003-01-14 13:34:11 UTC


Attachments (Terms of Use)

Description jbowman 2002-10-28 20:35:52 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2b) Gecko/20021021
Phoenix/0.3

Description of problem:
gnome-libs has taken over libdb1 and libdb2, resulting in *very* bizarre package
dependencies (i.e. net-snmp requires libdb.so.2, which is only provided by
gnome-libs, thereby linking net-snmp to gnome-libs for no othe reason).

Prior to 8.0, db1 and db2 libraries were either provided by their own rpms or as
part of the glibc package. Either one of these behaviours would be far, far
preferable to the current solution.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Do not install gnome-libs.
2. Attempt to install net-snmp.
3.
	

Additional info:

Comment 1 Havoc Pennington 2002-10-29 06:11:55 UTC
db1 and db2 would have been removed entirely, they exist only to preserve the
gnome-libs 1.4 ABI. db1/db2 are deprecated and not really provided for use
outside of gnome-libs.

Comment 2 jbowman 2002-10-29 13:47:57 UTC
db2 is also used by net-snmp, however, which is a member of the 'base' group.
This  makes gnome-libs a mandatory installation, no matter which way you slice
it, because the contents of the 'base' group are forcibly installed by anaconda.
By rolling libdb2 into gnome-libs, gtk+ (and other assorted dependencies of
gnome-libs) are now mandatory in *every* RedHat installation, despite the wishes
of the installer.

I understand it's not really feasible to fix this at the 8.0 level, but if db2
is going to continue to be packaged in 8.1 alongside other packages that depend
on it, could you please seperate back out into its individual package as it was
during the 7.x series?

Comment 3 Havoc Pennington 2002-10-29 14:08:14 UTC
Oh, net-snmp is ours - it should not link to db2.
That's the first thing to fix.

Comment 4 Phil Knirsch 2002-11-04 16:03:49 UTC
Will be fixed in a rawhide version real soon... :-)

Read ya, Phil

Comment 5 Phil Knirsch 2003-01-14 13:34:11 UTC
OK, fixed in latest rawhide versions.

Read ya, Phil


Note You need to log in before you can comment on or make changes to this bug.