Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 76888 - Running a program from C Perspective->No output seen
Summary: Running a program from C Perspective->No output seen
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Developer Suite
Classification: Retired
Component: eclipse
Version: 1.0
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: eclipse-bugs
QA Contact: eclipse-bugs
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-10-28 19:26 UTC by Need Real Name
Modified: 2007-04-18 16:47 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2003-07-24 22:08:26 UTC


Attachments (Terms of Use)

Description Need Real Name 2002-10-28 19:26:57 UTC
Description of Problem:
If a program is run from the C Perspective, there is no console view in the
perspective by default to  see output from the program. Can manually add the
Console view from the debug perspective to see the output but it  should be
there by default - a user will intuitively run their program from the
C-perspective and THEN choose to debug if any problems are found. 

Version-Release number of selected component (if applicable):


How Reproducible:
always

Steps to Reproduce:
1. Create and build a project where the program sends output to the console
2. Run program in C perspective
3. No output seen

Actual Results:


Expected Results:


Additional Information:

Comment 1 Need Real Name 2002-11-12 15:34:39 UTC
I filed a bug regarding this on eclipse.org:

http://bugs.eclipse.org/bugs/show_bug.cgi?id=25972

According to them its an Eclipse related bug that comes up only on linux. 
Couldn't a possible workaround to it be that the Console view (Windows->show
View->Debug->Console) be added into the C perspective by default, the way it is
in the Debug Perspective. This way, whether it "appears" automatically when a
program is run will not be an issue. At most, the Console view will have to
become active when a program is run. Would we be able to put this in ourself if
they chose to wait for the more general fix?

Comment 2 Jeremy Handcock 2003-07-24 22:08:26 UTC
This has since been fixed - a console view now pops up automatically when a
program is run.  Closing.


Note You need to log in before you can comment on or make changes to this bug.