Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 76886 - pcmcia modules not loading after updating kernel
Summary: pcmcia modules not loading after updating kernel
Keywords:
Status: CLOSED DUPLICATE of bug 78195
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: kernel-pcmcia-cs
Version: 6.2
Hardware: i586
OS: Linux
medium
high
Target Milestone: ---
Assignee: Arjan van de Ven
QA Contact: Brian Brock
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-10-28 19:05 UTC by TARogue
Modified: 2007-04-18 16:47 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2006-02-21 18:50:03 UTC


Attachments (Terms of Use)

Description TARogue 2002-10-28 19:05:36 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 Galeon/1.2.6 (X11; Linux i686; U;) Gecko/20020916

Description of problem:
I updated my laptop running Red Hat 6.2 to the latest kernel (2.2.22-6.2.2) and
kernel-pcmcia-cs. When I rebooted withthe new kernel pcmcia wouldn't load.
Attempting to do it manually gave me lots of unresolved symbols, and running
'depmod -v | grep fail' gave me lots of lines beginning with xftw.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.run /etc/rc.d/init.d/pcmcia stop
2.run /etc/rc.d/init.d/pcmcia start
	

Actual Results:  Starting PCMCIA services:
modules/lib/modules/2.2.22-6.2.2/pcmcia/pcmcia_core.o: unresolved symbol
request_mem_region
/lib/modules/2.2.22-6.2.2/pcmcia/pcmcia_core.o: unresolved symbol release_mem_region
/lib/modules/2.2.22-6.2.2/pcmcia/i82365.o: unresolved symbol pci_set_power_state
/lib/modules/2.2.22-6.2.2/pcmcia/i82365.o: unresolved symbol pci_enable_device
/lib/modules/2.2.22-6.2.2/pcmcia/i82365.o: unresolved symbol unregister_ss_entry
/lib/modules/2.2.22-6.2.2/pcmcia/i82365.o: unresolved symbol pci_irq_mask
/lib/modules/2.2.22-6.2.2/pcmcia/i82365.o: unresolved symbol register_ss_entry
/lib/modules/2.2.22-6.2.2/pcmcia/i82365.o: unresolved symbol CardServices
/lib/modules/2.2.22-6.2.2/pcmcia/ds.o: unresolved symbol proc_pccard
/lib/modules/2.2.22-6.2.2/pcmcia/ds.o: unresolved symbol CardServices
 cardmgr


Expected Results:  Starting PCMCIA services:         [OK]


Additional info:

Comment 1 giulioo 2003-01-19 16:49:13 UTC

*** This bug has been marked as a duplicate of 78195 ***

Comment 2 Red Hat Bugzilla 2006-02-21 18:50:03 UTC
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.


Note You need to log in before you can comment on or make changes to this bug.