Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 76884 - Back channel on print jobs causes linus to drop net connection
Summary: Back channel on print jobs causes linus to drop net connection
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: printconf
Version: 7.3
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Tim Waugh
QA Contact: Ben Levenson
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-10-28 18:28 UTC by Tom Oswald
Modified: 2007-04-18 16:47 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2003-01-20 19:01:28 UTC


Attachments (Terms of Use)

Description Tom Oswald 2002-10-28 18:28:58 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.1) Gecko/20020827

Description of problem:
I created a print queue via the gui print configuration tool.  The queue is of
type JetDirect, i.e., rawprint port 9100.  When I use lpr to send a print job
that has back channel data to this print queue, linux will immediately abort the
network connection when the back channel data is sent to it.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.lpr a postscript job with back channel to a JetDirect print queue.
2.If the back channel occurs early, not all of the pages will print because
linux drops the connection.
3.
	

Actual Results:  For example, an 18 page job will never print all 18 pages.  It
may range from 15 5o 17 depending upon the amount of print data presently in the
printer network stack when linux aborts the connection.  This is seem with
Postscript printers made by Sharp and HP.

Expected Results:  All 18 pages should have printed with a network closure after
all of the print data was sent.

Additional info:

Comment 1 Tim Waugh 2003-01-20 19:01:03 UTC
This is fixed in the current beta.  I expect we'll do a bug-fix advisory in due
course.


Note You need to log in before you can comment on or make changes to this bug.