Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 76875 - Finnish version missing
Summary: Finnish version missing
Keywords:
Status: CLOSED DUPLICATE of bug 108720
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: openoffice.org
Version: 8.0
Hardware: All
OS: Linux
medium
low
Target Milestone: ---
Assignee: Dan Williams
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-10-28 16:09 UTC by Erno Vuori
Modified: 2007-04-18 16:47 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2004-10-07 08:21:47 UTC


Attachments (Terms of Use)
Patch to get finnish *35.res files when building from srpm (deleted)
2002-10-28 16:11 UTC, Erno Vuori
no flags Details | Diff
up to date strings for finnish version (deleted)
2002-10-28 16:26 UTC, Erno Vuori
no flags Details | Diff

Description Erno Vuori 2002-10-28 16:09:47 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.1) Gecko/20021003

Description of problem:
OpenOffice does not seem to include Finnish language. Lang.mk and postset.mk in
$SRC_ROOT/solev/inc are broken. Patch to get finnish res files when
building from srpm is.

--- oo_1.0.1_src/solenv/inc/lang.mk.jj	2002-10-28 18:28:28.000000000 +0200
+++ oo_1.0.1_src/solenv/inc/lang.mk	2002-10-28 18:29:09.000000000 +0200
@@ -225,9 +225,9 @@ LANGEXT=03
 RSCLANG=NORWEGIAN $(IBM_PC_850)
 LANGEXT=47
 .ENDIF
-.IF "$(solarlang)" == "suom"
+.IF "$(solarlang)" == "finn"
 RSCLANG=FINNISH $(IBM_PC_850)
-LANGEXT=05
+LANGEXT=35
 .ENDIF
 .IF "$(solarlang)" == "hung"
 RSCLANG=HUNGARIAN $(IBM_PC_852)

--- oo_1.0.1_src/solenv/inc/postset.mk.jj	2002-10-28 18:28:37.000000000 +0200
+++ oo_1.0.1_src/solenv/inc/postset.mk	2002-10-28 18:29:40.000000000 +0200
@@ -301,7 +301,7 @@ finn$(LANG_GUI)*=$(default$(LANG_GUI))
 lang_35=finn
 longlang_35=finnish
 langext_35=35
-rsclang_35=-lgFINNiSH $(IBM_PC_437)
+rsclang_35=-lgFINNISH $(IBM_PC_850)
 rescharset_35=$(finn$(LANG_GUI))
 RCLANGFLAGS_35+= -d FINNISH
 iso_35=fi

Configure line with finnish should go like; --with-lang=FINN

Comment 1 Erno Vuori 2002-10-28 16:11:28 UTC
Created attachment 82385 [details]
Patch to get finnish *35.res files when building from srpm

Comment 2 Erno Vuori 2002-10-28 16:26:55 UTC
Created attachment 82387 [details]
up to date strings for finnish version

Comment 3 Dan Williams 2004-04-10 18:56:01 UTC

*** This bug has been marked as a duplicate of 108720 ***

Comment 4 Caolan McNamara 2004-10-07 08:21:47 UTC
close as duplicate of 108720


Note You need to log in before you can comment on or make changes to this bug.