Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 76869 - bash resolves directories incorrectly when using ~ and TAB
Summary: bash resolves directories incorrectly when using ~ and TAB
Keywords:
Status: CLOSED DUPLICATE of bug 72512
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: bash
Version: 8.0
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Tim Waugh
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-10-28 13:43 UTC by Frode Tennebø
Modified: 2008-05-01 15:38 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2002-10-28 17:38:15 UTC


Attachments (Terms of Use)

Description Frode Tennebø 2002-10-28 13:43:28 UTC
Description of Problem:

If you want to RUN a program where the path is relative to ~/ and it 
resides in a subdirectory, eg. ~/bin/foo, bash fails to identify the 
directory correctly if TAB is pressed.

Version-Release number of selected component (if applicable):

bash-2.05b$ bash --version
GNU bash, version 2.05b.0(1)-release (i686-pc-linux-gnu)

How Reproducible:

Always.

Steps to Reproduce:
1. bash-2.05b$ ~/bi[tab]
2. 
3. 

Actual Results:
bash-2.05b$ ~/bin[space]


Expected Results:
bash-2.05b$ ~/bin/

Additional Information:
/home/bar/bi[tab] works as expected.

Comment 1 Tim Waugh 2002-11-07 14:15:13 UTC

*** This bug has been marked as a duplicate of 72512 ***


Note You need to log in before you can comment on or make changes to this bug.