Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 76834 - named does not start
Summary: named does not start
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: bind
Version: 8.0
Hardware: i686
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Daniel Walsh
QA Contact: Ben Levenson
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-10-27 20:48 UTC by Need Real Name
Modified: 2007-04-18 16:47 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2003-08-01 19:55:30 UTC


Attachments (Terms of Use)

Description Need Real Name 2002-10-27 20:48:25 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i586; en-US; rv:1.0.1) Gecko/20020830

Description of problem:
Trying to start named as root with service named start fails. The
/var/log/messages contains the following 

Oct 27 21:34:13 borgcube named[2313]: listening on IPv4 interface eth0,
192.168.0.3#53
Oct 27 21:34:13 borgcube named[2313]: could not configure root hints from
'named.ca': file not found
Oct 27 21:34:13 borgcube named[2313]: loading configuration: file not found
Oct 27 21:34:13 borgcube named[2313]: exiting (due to fatal error)
Oct 27 21:34:13 borgcube named: named startup failed

Checking the status with 'service named status' produces 

rndc: Couldn't find server 'localhost': Name or service not known

I have used bindconf/redhat-config-bind but I have not enetered any records. 

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.run bindconf->apply 
2.service named start/restart/status
	

Actual Results:  [root@borgcube log]# service named start
Starting named:                                            [FAILED]

[root@borgcube log]# service named status
rndc: Couldn't find server 'localhost': Name or service not known


Additional info:

All the binarys are RPMS from RH 8.0

Comment 1 Daniel Walsh 2003-01-07 16:29:52 UTC
redhat-config-bind put a file /etc/named.custum on your disk.  This file
contains the lines
zone  "." { 
	type hint; 
	file  "named.ca";
};

Remove these lines or install cache-nameserver to fix this problem.


Note You need to log in before you can comment on or make changes to this bug.