Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 76827 - genhdlist (from the anaconda source package) doesn't work
Summary: genhdlist (from the anaconda source package) doesn't work
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: anaconda
Version: 8.0
Hardware: i386
OS: Linux
high
medium
Target Milestone: ---
Assignee: Michael Fulbright
QA Contact: Brock Organ
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-10-27 17:52 UTC by Need Real Name
Modified: 2007-03-27 03:58 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2002-10-27 17:52:44 UTC


Attachments (Terms of Use)

Description Need Real Name 2002-10-27 17:52:38 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.0.1)
Gecko/20020823 Netscape/7.0

Description of problem:
1. genhdlist can't be compiled out of box
2. It failed to work (segmentation fault) 

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Install the anaconda source package
2. cd util
3. make genhdlist


Actual Results:  

Please note that I don't have my RH8 box at hand, I'll try to be as accurate as
possible.

Symptom: rpm.h not found.
Reason: -I point to the wrong location
Solve: use -I/user/include/rpm instead of -I/user/include/rpm-4.0.4

Symptom: -lrpm-4.0.4 not found. 
Reason: cc is looking for librpm4.0.4.a, but only librpm4.0.4.so is installed.
So are the rest of libraries (librpmdb, etc)
Solve: remove the -static compiler switch

Symptom: segmentation fault
Duplicate: Use it to generate the hdlist files as it is supposed to be. I am
able to generate hdlist files in previous RH versions.
Reason: ??
Solve: see below "Additional Information"



Expected Results:  hdlist & hdlist2 generated in base directory.

Additional info:

In order to look for other alternatives, I've tried the following:

- I install the rpm source release, compiled, and installed. But the problem
remains (still no librpm4.0.4.a, only librpm4.0.4.so installed)

- Tried to build against rpm-4.1 library. Found out that it is an irrelevant
issue because of one function (rpmReadHeader?) is dropped from 4.1, because of
the link failure.

Comment 1 Jeremy Katz 2002-10-30 19:16:22 UTC
You need to install the librpm404-devel package


Note You need to log in before you can comment on or make changes to this bug.