Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 76809 - Internet Config Wizard crash
Summary: Internet Config Wizard crash
Keywords:
Status: CLOSED DUPLICATE of bug 79693
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: internet-config
Version: 7.3
Hardware: i686
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Ngo Than
QA Contact: Ben Levenson
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-10-27 06:34 UTC by Need Real Name
Modified: 2007-04-18 16:47 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2006-02-21 18:50:02 UTC


Attachments (Terms of Use)

Description Need Real Name 2002-10-27 06:34:40 UTC
Description of Problem:  
  
Upon trying to change some things with my 'net config (ppp0), it crashed and  
gave the following message:  
 
Please visit http://bugzilla.redhat.com/bugzilla/ !  
File a bug against component redhat-config-network. Thank you!  
  
Traceback (innermost last):  
  File "/usr/sbin/internet-druid", line 1400, in ?  
    window = mainDialog('druid')  
  File "/usr/sbin/internet-druid", line 238, in __init__  
    if modus == 'druid': self.on_deviceAddButton_clicked(None)  
  File "/usr/sbin/internet-druid", line 473, in on_deviceAddButton_clicked  
    interface = NewInterfaceDialog()  
  File  
"/usr/sbin/../share/redhat-config-network/netconfpkg/gui/NewInterfaceDialog.py",  
line 82, in __init__  
    iface = iface_creator (self.toplevel, do_save = None, druid = self.druid)  
  File  
"/usr/sbin/../share/redhat-config-network/netconfpkg/gui/EthernetInterface.py",  
line 101, in __init__  
    self.hwDruid = ethernetHardware(self.toplevel)  
  File  
"/usr/sbin/../share/redhat-config-network/netconfpkg/gui/EthernetHardwareDruid.py",  
line 64, in __init__  
    self.setup()  
  File  
"/usr/sbin/../share/redhat-config-network/netconfpkg/gui/EthernetHardwareDruid.py",  
line 118, in setup  
    list.append(modInfo[i]['description'])  
KeyError: description  
  
  
  
Version-Release number of selected component (if applicable):  
  
*shrug*  
  
How Reproducible:  
  
Easy. Just let me try to go back into it....  
  
Steps to Reproduce:  
1. point   
2. click  
3. bang head  
  
Actual Results:  
 
will not allow any changes, exits immediately.  
  
Expected Results:  
 
hehehe.. well, it should work.. right? ;)  
  
Additional Information:  
 
running a NAT (masquerade).. eth0>ppp0 and bastille.  not sure if this would 
effect it.

Comment 1 Michael Schwendt 2002-10-27 22:45:49 UTC
Duplicate of bug #76446.


Comment 2 Cin 2002-11-09 16:50:01 UTC
Same problem as descripted here in bug 76809.





Comment 3 Ngo Than 2003-03-01 09:40:01 UTC

*** This bug has been marked as a duplicate of 79693 ***

Comment 4 Red Hat Bugzilla 2006-02-21 18:50:02 UTC
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.


Note You need to log in before you can comment on or make changes to this bug.