Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 76808 - pop3 and ftp stop responding until xinetd restarted
Summary: pop3 and ftp stop responding until xinetd restarted
Keywords:
Status: CLOSED DUPLICATE of bug 76146
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: xinetd
Version: 7.2
Hardware: i586
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Trond Eivind Glomsrxd
QA Contact: Brock Organ
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-10-27 06:09 UTC by David Ball
Modified: 2007-04-18 16:47 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2002-10-27 06:09:40 UTC


Attachments (Terms of Use)

Description David Ball 2002-10-27 06:09:34 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; .NET CLR 
1.0.3705)

Description of problem:
after update to xinetd-2.3.9-0.72 and kernel-2.4.18-17.7.x, mail and ftp stop 
responding occasionally. "netstat
-an" showed a bunch of connections on port 110 stuck in CLOSE_WAIT
status. Restarting XinetD gets mail and ftp working again, and
eliminates the connections in CLOSE_WAIT. The system is over 90% idle
with a load average of < 0.50 ( often < 0.0x ) so I don't think
it's a heavy load problem.

When I posted this to the XinetD mailing list, I heard from another
user with the same problem so it's not just my machine. He suggested 
the "netstat -an" check.


Version-Release number of selected component (if applicable):


How reproducible:
Didn't try


Additional info:

RH 7.2 with all patches current using up2date, including kernel-2.4.18-
17.7.x.  System is lightly loaded.

top shows
--- pasted ---
 10:18pm  up 8 days, 59 min,  1 user,  load average: 0.01, 0.02, 0.00
73 processes: 71 sleeping, 2 running, 0 zombie, 0 stopped
CPU states:  0.3% user,  2.5% system,  0.9% nice, 96.0% idle
Mem:   255880K av,  251824K used,    4056K free,       0K shrd,   16328K buff
Swap:  522072K av,   26708K used,  495364K free                  121692K cached
--- end pasted ---

Comment 1 Milan Kerslager 2002-10-28 16:48:19 UTC

*** This bug has been marked as a duplicate of 76146 ***


Note You need to log in before you can comment on or make changes to this bug.