Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 76803 - Alert msg on double-clicking Internet Configuration Wizard
Summary: Alert msg on double-clicking Internet Configuration Wizard
Keywords:
Status: CLOSED DUPLICATE of bug 76446
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: redhat-config-network
Version: 8.0
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Harald Hoyer
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-10-26 23:16 UTC by Burnell G ("Burnie") West
Modified: 2008-05-01 15:38 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2006-02-21 18:50:02 UTC


Attachments (Terms of Use)

Description Burnell G ("Burnie") West 2002-10-26 23:16:52 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.1) Gecko/20020823
Netscape/7.0

Description of problem:
Installed complete updates as of today.  Then, later, while exploring the system
I attempted to open the Internet Configuration Wizard.  This led immediately to
the following traceback information, and
asked me to file a bug against refhat-config-network:

Traceback (innermost last):
  File "/usr/sbin/internet-druid", line 1400, in ?
    window = mainDialog('druid')
  File "/usr/sbin/internet-druid", line 238, in __init__
    if modus == 'druid': self.on_deviceAddButton_clicked(None)
  File "/usr/sbin/internet-druid", line 473, in on_deviceAddButton_clicked
    interface = NewInterfaceDialog()
  File
"/usr/sbin/../share/redhat-config-network/netconfpkg/gui/NewInterfaceDialog.py",
line 82, in __init__
    iface = iface_creator (self.toplevel, do_save = None, druid = self.druid)
  File
"/usr/sbin/../share/redhat-config-network/netconfpkg/gui/EthernetInterface.py",
line 101, in __init__
    self.hwDruid = ethernetHardware(self.toplevel)
  File
"/usr/sbin/../share/redhat-config-network/netconfpkg/gui/EthernetHardwareDruid.py",
line 64, in __init__
    self.setup()
  File
"/usr/sbin/../share/redhat-config-network/netconfpkg/gui/EthernetHardwareDruid.py",
line 118, in setup
    list.append(modInfo[i]['description'])
KeyError: description

Local variables in innermost frame:
modInfo: <netconfpkg.Conf.ConfModInfo instance at 84d8cb8>
list: ['RealTek RTL8129', 'Raytheon Raylink/WebGear/Aviator PCMCIA wireless',
'SMC Ultra32 EISA', 'DEC 21*40 and clones', 'Lucent Orinoco/Melco PCMCIA
wireless (alternate)', 'SMC 91c92 series PCMCIA', 'Aironet 4500 PCI-ISA-i365
wireless', 'Intel EtherExpress/1000', 'PCI NE2000 clones', 'MiCom-Interlan
NI5010', '3Com 3c515 Corkscrew', 'SMC 83c170 EPIC/100', 'NI5210 ethernet',
'AT1500, HP J2405A, most NE2100/clone', 'MyriCOM MyriNET SBUS', '3Com
EtherLink16', 'AT&T/Lucent/Hitachi ISA WaveLAN', 'SiS 900/7016CI', 'Cabletron
E2100', 'NE1000, NE2000, and compatible', 'Intel EtherExpress Pro 100B', 'Allied
Telesis AT1700', 'Greenwigh GIrBIL IrDA', 'Older DEC 21040, most 21*40', 'NSC
IrDA', 'Sun Quad', 'ICL EtherTeam 16i/32 EISA', '3Com 3c590/3c595/3c90x/3cx980',
'3Com 3c589 series PCMCIA', 'Sun BigMac', 'ThunderLAN', '3Com 3c574 series
PCMCIA', 'Ansel Communications Model 3200', 'Aironet 4500 PCMCIA wireless',
'Xircom CBE-100 CardBus', 'General Instruments SB1000']
self: <netconfpkg.gui.EthernetHardwareDruid.ethernetHardware instance at 85427b8>
i: defxx


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Open System Settings.
2.Double-click Internet Connection Wizard.
3.
	

Actual Results:  Traceback (consistent)

Expected Results:  The wizard ought to work.

Additional info:

I'm unsure about my network setup.  It's a NetGear MR314 wireless router
connected to a DSL (198.162.0.1) withmy laptop (Win2K), my Linux i386
box, and another Win 98 PC (all hard-wired with CAT-5 cabling).  The file
/etc/hosts doesn't appear correct to me, but I don't know what it
should look like.  It says:

# Do not remove the following line, or various programs
# that require network functionality will fail.
127.0.0.1	localhost.localdomain	dhcppc3
127.0.0.1	localhost.localdomain	dhcppc2
127.0.0.1	localhost.localdomain	dhcppc3
198.162.0.2	user-jetpa4xt33	
198.162.0.3	C57972-M	

0.2 is my Linux box; 0.3 is the Win 98 box; the laptop does not show.
When the bug first appeared, the first line in this file was dhcppc1; I opened
Network Configuration in the System Settings file, and tried to delete the first
two 127.0.0.1 entries; the result was a change to the /etc/hosts file as shown
above.

Comment 1 Cristian Gafton 2002-11-01 03:11:12 UTC
assigned to proper component/folks

Comment 2 Harald Hoyer 2002-11-13 14:33:02 UTC
hmm, you probably should fix /etc/hosts by hand

Comment 3 Craig Margenau 2002-11-23 15:51:27 UTC
I get the same exact bug, using Linux 7.3 Pro w/ all the latest patches.  I use
a LinkSys Ethernet Adapter and a LinkSys Wireless Access Point Router w/ 4-port
switch, Model# BEFW11S4.  My Linux box is plugged directly into this Router, not
using the Wireless feature.

Comment 4 Harald Hoyer 2003-01-13 13:04:31 UTC

*** This bug has been marked as a duplicate of 76446 ***

Comment 5 Red Hat Bugzilla 2006-02-21 18:50:02 UTC
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.


Note You need to log in before you can comment on or make changes to this bug.