Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 76798 - redhat-date-config, dateconfig - traceback (in __init__, no attribute tz)
Summary: redhat-date-config, dateconfig - traceback (in __init__, no attribute tz)
Keywords:
Status: CLOSED DUPLICATE of bug 74797
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: redhat-config-date
Version: 8.0
Hardware: i686
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Brent Fox
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-10-26 22:11 UTC by Antonio
Modified: 2008-05-01 15:38 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2002-10-26 22:11:13 UTC


Attachments (Terms of Use)

Description Antonio 2002-10-26 22:11:07 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.1) Gecko/20021003

Description of problem:
always get traceback when running redhat-date-config and dateconfig
Also when launching from menu. nothing happens.

PIII 533, 256 RAM, 15GB, RH8.0 fresh install and up2date
(see actual results for traceback)

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.running dateconfig
2.running redhat-config-date

	

Actual Results:  [root@###### root]# redhat-config-date
Traceback (most recent call last):
  File "/usr/share/redhat-config-date/redhat-config-date.py", line 35, in ?
    mainWindow.mainWindow().stand_alone()
  File "/usr/share/redhat-config-date/mainWindow.py", line 181, in __init__
    self.timezonePage = timezone_gui.timezonePage()
  File "/usr/share/redhat-config-date/timezone_gui.py", line 50, in __init__
    self.tz = TimezoneMap(zonetab, self.default, map=path)
  File "/usr/share/redhat-config-date/timezone_map_gui.py", line 139, in __init__
    self.setCurrent(self.currentEntry)
  File "/usr/share/redhat-config-date/timezone_map_gui.py", line 180, in setCurrent
    self.markers[self.currentEntry.tz].hide()
AttributeError: 'NoneType' object has no attribute 'tz'



Expected Results:  popping up the dateconfig window..

Additional info:

Comment 1 Antonio 2002-10-26 22:19:00 UTC

*** This bug has been marked as a duplicate of 74797 ***


Note You need to log in before you can comment on or make changes to this bug.