Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 76792 - OpenSSH is proposed as update to non-commercial SSH
Summary: OpenSSH is proposed as update to non-commercial SSH
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: up2date
Version: 8.0
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Adrian Likins
QA Contact: Jay Turner
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-10-26 20:08 UTC by Kai Thomsen
Modified: 2015-01-08 00:01 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2002-10-26 20:08:32 UTC


Attachments (Terms of Use)

Description Kai Thomsen 2002-10-26 20:08:25 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 Galeon/1.2.6 (X11; Linux i686; U;) Gecko/20020830

Description of problem:
I have the non-commercial version of "SSH Secure Shell for Workstations 3.2"
(from ftp.ssh.com) installed in RPM format.  When I run up2date, I see the
package openssh-3.4p1-2 wrongly listed as an update.  Selecting it and letting
up2date do its work removes the package ssh-3.2.0 from my system and installs
the OpenSSH package.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. remove all OpenSSH packages
2. download source of non-commercial SSH version
3. build it
4. install it in RPM format using `checkinstall'
5. run up2date


Actual Results:  `openssh-3.4p1-2' is listed as an update package.

Expected Results:  There should be no OpenSSH packages listed, as none are
installed on my system.

Additional info:

$ rpm -qa openssh\*
$ rpm -q ssh
ssh-3.2.0-1
$ rpm -q --provides ssh
ssh
ssh = 3.2.0-1
$

Comment 1 Adrian Likins 2002-11-01 21:34:46 UTC
Our openssh packages "obsoletes" ssh, and up2date is following that
suggestion and replacing ssh with openssh. Ie, not a bug.

If you dont want this to happen, you can place ssh on the
package skip list.


Note You need to log in before you can comment on or make changes to this bug.