Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 76787 - Font's don't show up in apps
Summary: Font's don't show up in apps
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: rhl-release-notes-x86
Version: 8.0
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: John Ha
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-10-26 17:34 UTC by udippel
Modified: 2014-08-04 22:14 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2002-10-31 23:29:53 UTC


Attachments (Terms of Use)

Description udippel 2002-10-26 17:34:26 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 Galeon/1.2.6 (X11; Linux i686; U;) Gecko/20020830

Description of problem:
Maybe this isn't a technical bug but a bug in the Release Notes for 8.0?
I followed the instructions with respect to additional fonts:
"If you have fonts that you would like to add to your configuration, you can
copy them to ~/.fonts (or /usr/share/fonts), and run fc-cache directory. The
fonts will then be available." True; but for whom?? Here (fresh install) only
for 'Preferences->Font', where I could set them to be used on the Desktop (Gnome).
But to the apps (e.g. Mozilla) they were not. So I had to use the whole legacy
framework (chkfontpath -add, xfs restart) to get them available in the apps. Now
they are in Mozilla; e.g. In Gnumeric not (yet?), though. Neither in Abiword
(where I didn't expect them to be available, true).
Seems to be more of a mess than before ... or did I understand anything wrongly ?


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. (see above)
2.
3.
	

Actual Results:  A hell of a lot of (different) work to get 'my' truetype fonts
working in the apps

Expected Results:  you dump them (fonts) in a directory and voil`, there they
are for everyone

Additional info:

Comment 1 Owen Taylor 2002-10-31 23:29:45 UTC
We're slowly working on getting rid of legacy fonts; the
release notes should probably be clearer that ~/.fonts
only is for the new font system.


Comment 2 John Ha 2002-11-04 22:10:21 UTC
It should have been noted that only current applications that support
Xft/fontconfig will work with the instructions in the notes. I will amend the
release notes in the CVS repository now. Thanks for your input.


Note You need to log in before you can comment on or make changes to this bug.