Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 76780 - "strip" utility will destroy UPX compresses executables
Summary: "strip" utility will destroy UPX compresses executables
Keywords:
Status: CLOSED DUPLICATE of bug 81644
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: binutils
Version: 8.0
Hardware: i686
OS: Linux
high
high
Target Milestone: ---
Assignee: Jakub Jelinek
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-10-26 11:55 UTC by Joshua Jackson
Modified: 2006-02-21 18:50 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2006-02-21 18:50:02 UTC


Attachments (Terms of Use)

Description Joshua Jackson 2002-10-26 11:55:57 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.1) Gecko/20021003

Description of problem:
If "strip" is run on a UPX compressed executable, the result is a 92 byte
(useless) file.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.strip <executable_name>


Actual Results:  You get a 92 byte file as output

Expected Results:  Should not strip anything from the file... previous builds
performed as expected.

Additional info:

The following warning is issued:

strip: Warning: Output file cannot represent architecture UNKNOWN!

Comment 1 Jakub Jelinek 2002-12-04 17:02:30 UTC
Please provide a testcase.

Comment 2 Miloslav Trmac 2004-02-05 07:46:59 UTC
Bug 81644 contains a testcase.

*** This bug has been marked as a duplicate of 81644 ***

Comment 3 Red Hat Bugzilla 2006-02-21 18:50:02 UTC
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.


Note You need to log in before you can comment on or make changes to this bug.