Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 76763 - XF86 deadlocks with Voodoo 5500 PCI & DRI
Summary: XF86 deadlocks with Voodoo 5500 PCI & DRI
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: XFree86
Version: 8.0
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: X/OpenGL Maintenance List
QA Contact: David Lawrence
URL:
Whiteboard:
Depends On:
Blocks: 82778
TreeView+ depends on / blocked
 
Reported: 2002-10-25 23:36 UTC by Adam Kropelin
Modified: 2007-04-18 16:47 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2004-09-24 18:11:17 UTC


Attachments (Terms of Use)
Original XF86Config file, machine deadlocks when using this config (deleted)
2002-10-28 23:05 UTC, Adam Kropelin
no flags Details
Diff showing changes to original config file (disabling DRI) --X starts ok with this config (deleted)
2002-10-28 23:07 UTC, Adam Kropelin
no flags Details | Diff
`lspci -vn` output on machine exhibiting deadlock (deleted)
2002-10-28 23:08 UTC, Adam Kropelin
no flags Details
Info from /proc/version (deleted)
2002-10-28 23:09 UTC, Adam Kropelin
no flags Details

Description Adam Kropelin 2002-10-25 23:36:04 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.1) Gecko/20021003

Description of problem:
When running 'startx', the screen blanks and the machine deadlocks completely
(keybd LEDs do not respond, network ping does not respond). This happens when
DRI is enabled (and it is enabled by default). Removing the "DRI" section at the
top of /etc/X11/CF86Config and also commenting out the 'Load "dri"' line in the
Module section of the same file allows X to start successfully. This bug has
been around since at least RH 7.3.

Version-Release number of selected component (if applicable):
XFree86-4.2.0-72

How reproducible:
Always

Steps to Reproduce:
1. Just run 'startx' with the default XF86Config file provided by the RH 8.0
installer.
	

Actual Results:  System deadlocks as described.

Expected Results:  X desktop should have eventually appeared.

Additional info:

Hardware configuration is a little 'interesting':
2 CPU SMP P2-450 XEON
Intel 440 GX chipset
PCI Voodoo 5500 card --note PCI, not AGP

Comment 1 Mike A. Harris 2002-10-26 05:38:24 UTC
Please attach your X config file, log file, and the output of the following:

lspci -vn
cat /proc/version


Comment 2 Adam Kropelin 2002-10-28 23:05:48 UTC
Created attachment 82464 [details]
Original XF86Config file, machine deadlocks when using this config

Comment 3 Adam Kropelin 2002-10-28 23:07:05 UTC
Created attachment 82465 [details]
Diff showing changes to original config file (disabling DRI) --X starts ok with this config

Comment 4 Adam Kropelin 2002-10-28 23:08:46 UTC
Created attachment 82466 [details]
`lspci -vn` output on machine exhibiting deadlock

Comment 5 Adam Kropelin 2002-10-28 23:09:41 UTC
Created attachment 82467 [details]
Info from /proc/version

Comment 6 Adam Kropelin 2002-10-28 23:11:24 UTC
Cannot post X log file because machine deadlocks before any data gets written to
the log. If you have a suggestion on how to work around this, I'll give it a shot...

Comment 7 Mike A. Harris 2004-09-24 18:11:17 UTC
Please upgrade to Fedora Core 2 or later, and if this issue turns
out to still be reproduceable, please file a bug report in the
X.Org bugzilla located at http://bugs.freedesktop.org in the
"xorg" component.

Once you've filed your bug report to X.Org, if you paste the new
bug URL here, Red Hat will continue to track the issue in the
centralized X.Org bug tracker, and will review any bug fixes
that become available for consideration in future updates.



Note You need to log in before you can comment on or make changes to this bug.