Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 76761 - Mozilla "save as" dialog has no directories listed, crashes
Summary: Mozilla "save as" dialog has no directories listed, crashes
Keywords:
Status: CLOSED WORKSFORME
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: mozilla
Version: 7.3
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Christopher Blizzard
QA Contact: Ben Levenson
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-10-25 23:29 UTC by Burt Holzman
Modified: 2007-04-18 16:47 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2002-10-30 21:16:46 UTC


Attachments (Terms of Use)
gdb backtrace of mozilla crash (deleted)
2002-10-25 23:31 UTC, Burt Holzman
no flags Details

Description Burt Holzman 2002-10-25 23:29:58 UTC
Mozilla "save as" options no longer work: they pop up the file picker dialog 
box, but no directories are available.  You can get moz to crash by clicking on
"show hidden directories".  This is mozilla-1.0.1-2.7.2.

To reproduce, pick a site (www.google.com), right click on the image, and
select "save image as ..."; you get the bad dialog box.

This also seems to be a config munge or some sort of version incompatibility;
this occurred only after I ran up2date this morning.  Removing my ~/.mozilla
directory allows it to work properly.  This may be the same bug as reported
in Debian Woody
(http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=158041&repeatmerged=yes
)

I'll attach the gdb backtrace from the crash as well.

Comment 1 Burt Holzman 2002-10-25 23:31:13 UTC
Created attachment 82144 [details]
gdb backtrace of mozilla crash

Comment 2 Burt Holzman 2002-10-30 21:16:39 UTC
Well, I did a binary replace on files in my .mozilla dir; apparently the
XUL.mfasl  file is not completely compatible between upgrades.  Deleting this
file seemed to fix the problem, so that's a possible workaround.


Note You need to log in before you can comment on or make changes to this bug.