Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 76757 - xsane requires root priv to access scanner
Summary: xsane requires root priv to access scanner
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: kudzu
Version: 8.0
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Bill Nottingham
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-10-25 23:01 UTC by Adam Kropelin
Modified: 2014-03-17 02:32 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-09-23 19:38:53 UTC


Attachments (Terms of Use)

Description Adam Kropelin 2002-10-25 23:01:39 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.1) Gecko/20021003

Description of problem:
When running xsane as a mortal user it gives an error: "Failed to open device
'sm3600:1/3': Error during device I/O.". Running as root (and ignoring xsane's
warnings about the dangers of doing so) solves the problem. Scanner is a USB
Microtek ScanMaker 3600, FWIW.

Version-Release number of selected component (if applicable):
xsane-0.84-8

How reproducible:
Always

Steps to Reproduce:
1. Log in as a normal user and start X
2. Start xsane
3. Accept license agreement

	

Actual Results:  Error message cited above appears in a pop-up.

Expected Results:  Xsane main window should appear.

Additional info:

Comment 1 Tim Waugh 2002-11-07 14:03:27 UTC
If you make a symlink /dev/scanner pointing to the right device, this should
work fine.

It would be nice if kudzu did this for you I guess.

Comment 2 Forrest 2003-03-08 05:27:04 UTC
I had to add a script that changed the permissions of the device.  I create a
file called /etc/hotplug/usb/sm3600 containing:

#!/bin/bash
cd /etc/hotplug
. hotplug.functions
mesg setting permissions of $DEVICE
chmod a+rw $DEVICE

Then make this file executable (`chmod a+rx /etc/hotplug/usb/sm3600`).  This
works for me, but the /dev/scanner symlink doesn't seem to work.


Comment 3 Joerg Skottke 2004-03-21 15:23:56 UTC
Annoying thing. Add me to cc

Comment 4 Bill Nottingham 2005-09-23 19:38:53 UTC
Some of this was handled by USB hotplug scripts in later releases. For the
Fedora Core development stream, handling of this is done/needs to be done via
udev rules. Closing as WONTFIX for kudzu, as this is handled elsewhere in
current releases.


Note You need to log in before you can comment on or make changes to this bug.