Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 76740 - Hang during shutdown stopping pcmcia for 2.4.18-17.8.0
Summary: Hang during shutdown stopping pcmcia for 2.4.18-17.8.0
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: kernel-pcmcia-cs
Version: 8.0
Hardware: i686
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Dave Jones
QA Contact: Brian Brock
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-10-25 17:13 UTC by Need Real Name
Modified: 2015-01-04 22:02 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2004-11-25 08:25:23 UTC


Attachments (Terms of Use)

Description Need Real Name 2002-10-25 17:13:15 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2b) Gecko/20021016

Description of problem:
After upgrading from stock RH 8.0 to 2.4.18-17.8.0 kernel (using RHN), system
now hangs during shutdown when attempting to stop pcmcia; this hang did not/does
not occur when booting with the original 2.4.8-14 kernel installed with RH 8.0.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Boot system with 2.4.18-17.8.0 kernel
2. Shutdown system in the usual manner (e.g., from desktop logout)


Actual Results:  System hangs in shutdown, last few lines of output are as follows:

Stopping pcmcia: cardmgr[524]: executing: './serial check ttyS3'
cardmgr[524]: executing: './serial stop ttyS3'
ttyS3 unloaded
[hangs at this point]


Expected Results:  Shutdown messages continue and system halts as normal.

Additional info:

System information:

Dell Latitude CPx J650GT (256MB memory)
Dell FlashBIOS version A15
Xircom CreditCard Ethernet 10/100 + Modem 56 PC Card

Installed RH 8.0 as clean install into using workstation configuration (with
minor customizations) and default partitioning.

Comment 1 Need Real Name 2002-10-28 12:20:59 UTC
I'm having the same problem, though mine says


Stopping pcmcia: cardmgr[***]: executing: './network stop eth0'
<hangs>

Looked similar to the bug #52270, but that didn't help. OK if I use the old
kernel to boot.

Comment 2 Jeffrey R. Pych 2002-10-30 14:08:29 UTC
Same behavior here with Toshiba 550CDT and Xircom 10/100 Ethernet.  Works
normally with old kernel.

Comment 3 Need Real Name 2002-10-31 07:14:44 UTC
I am also experiencing this problem using a Sony PCG-F690K and a Xircom 10/100
ethernet/modem card that worked fine with the old kernel.

Comment 4 Need Real Name 2002-10-31 23:44:23 UTC
I didn't mention it but my system is a Sony PCG-F670 with a Xircom 10/100
Ethernet card.
Looks like it's a problem specific to Xircom cards?


Note You need to log in before you can comment on or make changes to this bug.