Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 76711 - apmd doesn't detect dell inspiron 2650 battery
Summary: apmd doesn't detect dell inspiron 2650 battery
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: kernel
Version: 8.0
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Arjan van de Ven
QA Contact: Brian Brock
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-10-25 09:20 UTC by Need Real Name
Modified: 2007-04-18 16:47 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2003-06-08 15:42:14 UTC


Attachments (Terms of Use)

Description Need Real Name 2002-10-25 09:20:38 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1)

Description of problem:
APM seems not to "see" the battery: it always notifies that the laptop is AC 
alimented even when the AC cable is unplugged. Moreover, the battery icon is 
always showing an empty status, the tooltip displays "Battery not present" and 
the percentage is "N/A" even though the battery is half or even fully charged; 
it seems to me that APM doesn't detect the battery somehow.
The daemon apmd actually starts at the system startup and keeps running until 
shutdown, but in the system logs there is a message warning that the charge of 
the battery is -1%. 
I am sure that the battery itself is finely working because other OS detect it 
properly, so the problem must be somewhere in APM (perhaps in the APM bios 
kernel module).

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Startup Linux RH 8.0 (kernel 2.4.18-17.8.0)
2. Add the APM icon to the taskbar if it's not already present
3. Simply try unplugging and plugging the AC cable and see what the APM frame 
reports; also try and check the battery status and charge
	

Additional info:

I tried to download a newer version of APM, but the most up-to-date rpm pkg 
available was the one shipped along with the kernel I have.
On the APM mailing list, other peole reported similar problems with other Dell 
laptops (7500)an RH Linux 7.3.

Comment 1 Bill Nottingham 2003-05-19 20:43:13 UTC
This is an interaction issue between the BIOS and the kernel APM driver.

Comment 2 Alan Cox 2003-06-08 15:42:14 UTC
BIOS problem, not one we can fix



Note You need to log in before you can comment on or make changes to this bug.