Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 76695 - xpdf fails to show anything from some file
Summary: xpdf fails to show anything from some file
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: xpdf
Version: 8.0
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Ngo Than
QA Contact: Mike McLean
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-10-24 23:36 UTC by Michal Jaegermann
Modified: 2007-04-18 16:47 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2002-10-24 23:36:50 UTC


Attachments (Terms of Use)

Description Michal Jaegermann 2002-10-24 23:36:42 UTC
Description of Problem:

I got recently a pdf file for which xpdf shows only blank pages.
'pdfinfo' shows the following information about it:

Tagged:       no
Pages:        6
Encrypted:    no
Page size:    612 x 792 pts (letter)
File size:    139423 bytes
Optimized:    yes
PDF version:  1.4

It is true that errors like that are generated

Error (0): PDF file is damaged - attempting to reconstruct xref table...
Error (23193): Unknown compression method in flate stream
Error (26807): Unknown compression method in flate stream
Error (22004): Unknown compression method in flate stream
Error (5423): Unknown compression method in flate stream
Error (7891): Unknown compression method in flate stream
Error (9985): Unknown compression method in flate stream
Error (12089): Unknown compression method in flate stream
Error (14049): Unknown compression method in flate stream
Error (16013): Bad FCHECK in flate stream
Error (18114): Unknown compression method in flate stream
Error (20180): Unknown compression method in flate stream
Error (105468): Bad FCHECK in flate stream
Error (109548): Unknown compression method in flate stream
Error (116550): Unknown compression method in flate stream
Error (82374): Unknown compression method in flate stream
Error (105468): Bad FCHECK in flate stream
Error (109548): Unknown compression method in flate stream
Error (87911): Unknown compression method in flate stream

Neverthless quite old 'acroread' complains but still shows all
contents.

This is the same with xpdf-1.01-8 from RH 8.0 and xpdf-1.00-3 as current
in 7.3

I can provide that file if requested (at least if requested within
a reasonable time).

Comment 1 Ngo Than 2002-12-08 21:28:20 UTC
could you please provide this test file please? or please try xpdf-2.01 in
rawhide if it fixes this problem.

please reopen this bug, if it's not fixed in xpdf-2.01 in the rawhide.

Comment 2 Michal Jaegermann 2002-12-08 23:20:45 UTC
I had some exchange with Derek N., the author of xpdf, about the issue.
The problem is that fonts in the file in question are damaged and xpdf
parser, even in the current version, does not know how to handle the situation.
This may change in the future. Acroread, even pretty old one, indeed does
comes in that situation markedly better.

If you still desire the file which exhibits the trouble drop me a line.


Note You need to log in before you can comment on or make changes to this bug.