Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 76690 - shortage of uploaded packages
Summary: shortage of uploaded packages
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Network
Classification: Red Hat
Component: RHN/Channels
Version: RHN Stable
Hardware: All
OS: Linux
medium
high
Target Milestone: ---
Assignee: Todd Warner
QA Contact: jkomendar
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-10-24 22:27 UTC by Isaiah Weiner
Modified: 2007-04-18 16:47 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2002-10-25 17:36:10 UTC


Attachments (Terms of Use)

Description Isaiah Weiner 2002-10-24 22:27:09 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 Galeon/1.2.6 (X11; Linux i686; U;) Gecko/20020913

Description of problem:
No matter how many times I create, populate, delete a new base
channel, I only get 25 packages identified as uploaded.  The first time
there were close to 900, which is still many many hundred short.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. upload packages
2. click 'clear cache' link on website when viewing channel contents
	

Actual Results:  25 packages appeared.

Expected Results:  ~1700 packages should have appeared.

Additional info:

Comment 1 Greg DeKoenigsberg 2002-10-24 23:03:43 UTC
Joe, can you reproduce this problem?  It looks like it might be a pagination
problem, but to test you'll need to load a whole bunch of custom packages.  When
you can reproduce, hand off to Robin for troubleshooting.

Comment 2 Greg DeKoenigsberg 2002-10-25 16:45:38 UTC
Joe cannot replicate the problem.  Isaiah, do you get error messages when you
sue the rhn_package_manager?  Any diagnostic info that you can share?

Comment 3 Isaiah Weiner 2002-10-25 16:51:37 UTC
I get no error messages.  rhn_package_manager does mention the package has
already been submitted, after it uploads it.  On the website, I click the
refresh content option on the page, and the 'click this when you're done
modifying the contents of the channel' link.  I get 25 packages.  The base
channel name is cisco-linux-i386-7.1 if you're interested.



Comment 4 Josef Komenda 2002-10-25 16:56:08 UTC
What command string are you using to upload the packages? I used 

rhn_package_manager -v --nosig -d /root/5.2 -c joe-base --username=jkomenda
--password=pink4all



Comment 5 Greg DeKoenigsberg 2002-10-25 16:58:21 UTC
Also, rpm -qa | grep rhn would probably be helpful.

Comment 6 Isaiah Weiner 2002-10-25 17:05:58 UTC
Everything is up to date:

$ rpm -qa | grep rhn
python-docs-1.5.2-36.rhn.2.7x
rhns-auth-daemon-1.2.4-13
rhns-proxy-broker-1.2.4-13.7.2
python-devel-1.5.2-36.rhn.2.7x
python-tools-1.5.2-36.rhn.2.7x
rhns-certs-tools-1.2.4-10
rhns-proxy-1.2.4-13.7.2
rhn_register-2.8.27-1.7.2
rhn_register-gnome-2.8.27-1.7.2
rhns-common-1.2.4-13.7.2
rhns-proxy-redirect-1.2.4-13.7.2
rhns-proxy-package-manager-1.2.4-3
mod_python-2.7.6-7rhn
python-1.5.2-36.rhn.2.7x
tkinter-1.5.2-36.rhn.2.7x
rhns-proxy-docs-1.2.4-13.7.2

The only applicable update to the 7.2 system is mod_python, which the
documentation made quiet clear should not be applied.

Here is my command:

sudo rhn_package_manager -v -c "cisco-linux-i386-7.1"
--username="cisco_ecs_iweiner" *

The contents of the directory are all 7.1+powertools packages.


Comment 7 Greg DeKoenigsberg 2002-10-25 17:18:57 UTC
Pulled directly from the 7.1 + powertools channels, right?  Then these packages
are already in the database with the same NVRE and MD5sum, correct?  I would
presume that the import of those packages would fail, and we should see some
errors *somewhere*.  Todd, can you take a look at this?

Comment 8 Isaiah Weiner 2002-10-25 17:36:02 UTC
I didn't pull them from the channel, they're from an FTP site mirror.  But the
packages are still the same.

When run without -v, _no_ output is yielded.

Comment 9 Isaiah Weiner 2002-10-29 23:59:57 UTC
New proxy updates (today) fixed this.


Note You need to log in before you can comment on or make changes to this bug.