Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 76689 - unique package directories per channel?
Summary: unique package directories per channel?
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Network
Classification: Red Hat
Component: RHN/Channels
Version: RHN Stable
Hardware: All
OS: Linux
medium
high
Target Milestone: ---
Assignee: Greg DeKoenigsberg
QA Contact: jkomendar
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-10-24 22:17 UTC by Isaiah Weiner
Modified: 2007-04-18 16:47 UTC (History)
9 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2002-10-29 22:54:15 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Isaiah Weiner 2002-10-24 22:17:21 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 Galeon/1.2.6 (X11; Linux i686; U;) Gecko/20020913

Description of problem:
I need to be able to guarantee I'm using a fresh copy of a package even if the
rhn_package_manager tool believes it's already been uploaded and copied per
identical NVR.  Can I specify a unique package directory for individual
channels, in this case a base channel, without changing the package directories
for all the channels hosted on a proxy?

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. foo
2. bar
3. baz
	

Additional info:

Comment 1 Greg DeKoenigsberg 2002-10-24 22:37:01 UTC
I presume that the scenario is as follows: you want to take a package from a
base Red Hat channel, let's say foo-1.31-8, and you want to place it into a base
channel.  So you download foo-1.31-8 and then attempt to upload it into the
private base channel, and it fails because a unique constraint is violated.

If this is correct, would you be satisfied with the ability to assign foo-1.31.8
directly to the new base channel without having to re-upload?  Would that be
sufficient?

Comment 2 Isaiah Weiner 2002-10-24 22:44:24 UTC
That would be splendid.

Comment 3 Mihai Ibanescu 2002-10-24 22:52:01 UTC
Please note that no uniqueness constraint violation should occur, but (if the
package is present both in a Red Hat base channel and a custom subchannel) an
ambiguity can occur.

Comment 4 Isaiah Weiner 2002-10-24 23:13:11 UTC
The package is present in a Red Hat base channel and a custom base channel.  The
bug still occurs.

Comment 5 Isaiah Weiner 2002-10-29 17:34:35 UTC
Do you need any more information from me?  When can I expect a status update or
some form of instruction?

Comment 6 Mihai Ibanescu 2002-10-29 22:54:09 UTC
We were unable to reproduce this problem with the current code that we have.
This is what jkomenda tried:

- uploaded 96 packages from 7.2 into a fresh base channel

He can see all of them on the web site.

I would suggest to run up2date -u on the proxy machine. This should give you the
latest proxy code, that we pushed live an hour ago. There were some bugfixes
that may have fixed your problem. Let me know if this does not solve the problem
for you.

Comment 7 Isaiah Weiner 2002-10-29 23:56:24 UTC
Fixed it. Closing bugs.


Note You need to log in before you can comment on or make changes to this bug.