Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 76685 - Text unreadable on konsole
Summary: Text unreadable on konsole
Keywords:
Status: CLOSED NEXTRELEASE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: kdebase
Version: 8.0
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Ngo Than
QA Contact: Ben Levenson
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-10-24 21:47 UTC by jfm2
Modified: 2007-04-18 16:47 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2006-08-04 20:28:19 UTC


Attachments (Terms of Use)

Description jfm2 2002-10-24 21:47:34 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i586; en-US; rv:1.0.1) Gecko/20020830

Description of problem:
On one of my boxes konsole is unusable, first fonts are nearly unreadable,
second refresh does not take place correctly, third
when you type "abc" it displays "a b c".  Strangely: when a program writes "abc"
then it displays "abc".

On another box everything is normal.  Differences between them: the nonworking
one is using french locales (the working one is using US ones), possibly has
different fonts and is using an S3 card while the other has an Nvidia. 



Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.On the non working box just fire konsole
2.
3.
	

Additional info:

Comment 1 Ngo Than 2002-11-04 11:12:59 UTC
perhaps you should setup the font in konsole, for example Lucidatywriter or
Monospace. It should fix this problem.

Comment 2 jfm2 2002-11-04 22:47:44 UTC
I made a vanilla "desktop install".  And I didn't get a usable configuration. 
This is a bug.  It could be not a KDE bug but an anaconda or config bug however
it is still a bug.

BTW there was mistake in my report: non working box is also using US locales.

Comment 3 jfm2 2002-11-05 10:09:42 UTC
More precisely I was using LANG=en_US.UTF-8.  Couldn't be a problem with the
handling of Unifix?

I also changed fonts and most of them didn't work.  One of the typewriter fonts
did but I cannot say its looks are good enough for showing it to Windows people.

I also notice that all KDE menus (not only konsole) look crappy (KDE in 7.3
looked good) and that there is a distinct delay each time a KDE application has
to open a menu (KDE in 7.3 did that instataneously) even when I redo it a second
later.  It is not a problem of lack of memory since there is no disk activity. 
Looks more like the KDE application is reparsing fonts each time I try to open a
menu.

Comment 4 jfm2 2002-11-05 20:58:54 UTC
I consider perfectly acceptable to get "Rawhide" or "will have to wait for 8.1"
as an answer since there is a solution (using other fonts).

But I think that when user selects a canned installation (desktop in my case),
does zero post install customizations and still gets an unusable konsole then
the defaults are wrong and should be changed.  In other words it is abug Thus it
is not right to answer "NOT A BUG"

Comment 5 Ngo Than 2002-11-05 23:57:29 UTC
a workaround to this problem you should change LANG=en_US.UTF-8 to
en_US.iso885915 in /etc/sysconfig/i18n.
 
It should work as in 7.3.

Comment 6 Bill Nottingham 2006-08-04 20:28:19 UTC
Red Hat Linux and Red Hat Powertools are currently no longer supported by Red
Hat, Inc. In an effort to clean up bugzilla, we are closing all bugs in MODIFIED
state for these products.

However, we do want to make sure that nothing important slips through the
cracks. If, in fact, these issues are not resolved in a current Fedora Core
Release (such as Fedora Core 5), please open a new issues stating so. Thanks.


Note You need to log in before you can comment on or make changes to this bug.