Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 76681 - Location of iface-specific dhclient files
Summary: Location of iface-specific dhclient files
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: initscripts
Version: 8.0
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Bill Nottingham
QA Contact: Brock Organ
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-10-24 21:28 UTC by Dan Morrill
Modified: 2014-03-17 02:32 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-09-29 20:21:00 UTC


Attachments (Terms of Use)

Description Dan Morrill 2002-10-24 21:28:51 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.1) Gecko/20020826

Description of problem:
/etc/sysconfig/network-scripts/ifup is responsible for invoking dhclient
where/when appropriate.  When run, ifup invokes dhclient to use a config file
specific to that device; this is fine, though it may be a matter of taste.

However, the config files are /etc/dhclient-${IFACE}.conf -- e.g.
/etc/dhclient-eth0.conf.  This is Ugly(TM) (IMO.)

These config files should go in either /etc/sysconfig/network-scripts, or at
least in a new /etc/dhclient.d/ or something.  (I personally favor
/etc/dhclient.d/, but whatever.)

Note that this is a style/consistency thing, not a true bug (since ifup does
work as-is.)  This may be related to bug 74862.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Boot up w/ DHCP enabled.
	

Actual Results:  dhclient looks for iface-specific config data in
/etc/dhclient-${IFACE}.conf

Expected Results:  dhclient should look for iface-specific config data in
something like /etc/dhclient.d/dhclient-${IFACE}.conf

Additional info:

Comment 1 Bill Nottingham 2005-09-29 20:21:00 UTC
Closing bugs on older, no longer supported, releases. Apologies for any lack of
response.

At this point, I doubt that this will change, it doesn't seem to be worth the
effort.


Note You need to log in before you can comment on or make changes to this bug.