Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 76675 - Missing 'tk' package dependency
Summary: Missing 'tk' package dependency
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: rhl-cg
Version: 8.0
Hardware: i686
OS: Linux
medium
low
Target Milestone: ---
Assignee: Tammy Fox
QA Contact: Brian Brock
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-10-24 20:42 UTC by Mark Harig
Modified: 2007-04-18 16:47 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2002-10-26 02:35:46 UTC


Attachments (Terms of Use)

Description Mark Harig 2002-10-24 20:42:03 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.1) Gecko/20021003

Description of problem:
When building the kernel from the kernel-source rpm (i.e.,
/usr/src/linux-2.4.x), the 'make xconfig' step fails because it cannot find the
tk utility program 'wish'.

Version-Release number of selected component (if applicable):
kernel-source-2.4.18-17.8.0

How reproducible:
Always

Steps to Reproduce:
1. Perform a vanilla 'Workstation' installation of Red Hat 8.0
2. Install the kernel-source .rpm package
3. Run 'up2date' (after registering) to get the latest patches
4. cd /usr/src/linux-2.4.18-17.8.0
5. Run 'make mrproper' at the shell prompt
6. Run 'make xconfig' at the shell prompt
	

Actual Results:  
# pwd
/usr/src/linux-2.4.18-17.8.0
# make xconfig
rm -f include/asm
( cd include ; ln -sf asm-i386 asm)
make -C scripts kconfig.tk
make[1]: Entering directory `/usr/src/linux-2.4.18-17.8.0/scripts'
gcc -Wall -Wstrict-prototypes -O2 -fomit-frame-pointer -c -o tkparse.o
tkparse.cgcc -Wall -Wstrict-prototypes -O2 -fomit-frame-pointer -c -o tkcond.o
tkcond.c
gcc -Wall -Wstrict-prototypes -O2 -fomit-frame-pointer -c -o tkgen.o tkgen.c
gcc -o tkparse tkparse.o tkcond.o tkgen.o
cat header.tk >> ./kconfig.tk
./tkparse < ../arch/i386/config.in >> kconfig.tk
KERNTYPE=`sed -n 's_^/\* Kernel type \(.*\) \*/_\1_p' /boot/kernel.h 2>/dev/null`; \
if [ -f configs/*-ERNTYPE.config ]; then \
        conf=`echo configs/*-ERNELTYPE.config`; \
        echo "set defaults \"\"" >> kconfig.tk; \
else \
        echo "set defaults \"arch/i386/defconfig\"" >> kconfig.tk; \
fi
echo "set ARCH \"i386\"" >> kconfig.tk
cat tail.tk >> kconfig.tk
chmod 755 kconfig.tk
make[1]: Leaving directory `/usr/src/linux-2.4.18-17.8.0/scripts'
wish -f scripts/kconfig.tk
make: wish: Command not found
make: *** [xconfig] Error 127


Expected Results:  

I expected what the Customization Guide has written:

"Components are listed in different levels of menus and are selected using a mouse."

Additional info:

I installed tk-8.3.3-74.i386.rpm from CD 2 of the Red Hat Installation disks.  I
then ran 'up2date' to check for any patches. There were none.
This resolved the problem described above for me, but should be resolved
elsewhere during the Red Hat installation process, or described in the
Customization Guide.

Comment 1 Arjan van de Ven 2002-10-24 20:45:15 UTC
this is a bit of a tricky issue
the problem is that if wish is Required:, effectively kernel-source would
require the X libraries to be installed...... which is something a lot of people
get upset about if I would have done that ;(

Comment 2 Mark Harig 2002-10-24 21:36:30 UTC
Then perhaps the Customization Guide needs to be changed?  When I saw 
that 'wish' was needed, I knew that meant tk was needed.  Many people would not 
know this.  Should the bug report Component be reassigned to 'rhl-cg'?
The manual's identifier is 'rhl-cg(EN)-8.0-Print-RHI (2002-08-14T17:28-0400).

Comment 3 Tammy Fox 2002-10-26 02:35:39 UTC
Thanks for the tip. I'll make sure it is mentioned in the next version.

Comment 4 Tammy Fox 2002-12-12 19:42:17 UTC
I added it to the source so that a note will appear in the next version
stating that the tk package is required for the wish command.


Note You need to log in before you can comment on or make changes to this bug.