Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 76674 - mc in ftpfs, symlinks with slash to directories
Summary: mc in ftpfs, symlinks with slash to directories
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: mc
Version: 8.0
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jindrich Novy
QA Contact: Jay Turner
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-10-24 20:38 UTC by Jan Martinek
Modified: 2015-01-08 00:01 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-05-24 10:52:40 UTC


Attachments (Terms of Use)

Description Jan Martinek 2002-10-24 20:38:52 UTC
Description of Problem:
while browsing remote ftp filesystem, mc
sees symlinks to directories as broken in case when symlink
is created with a slash on its end, like
linktodir -> directory/
and when attempt is made to follow the link in mc, error "No action taken"
is displayed. 

Version-Release number of selected component (if applicable):

mc-4.5.55-12.i386.rpm

How Reproducible:
try this:
mc ftp://uf.fce.vutbr.cz/pub/testsymlinks

Steps to Reproduce:
1. Make a symlink to a directory and add a slash "/" to the end
   of the symlink name.
2. connect to such filesystem via ftp (using mc)
3. the link named "link/" will appear as broken

Actual Results:
the link is shown as broken

Expected Results:
links should work as expected, double slash should be interpretted
as a single slash

Additional Information:

Comment 1 Leonard den Ottolander 2004-08-24 17:45:15 UTC
Would the FTP server be a Windows box? You can't add slashes to the
end of a link name on Linux...

Could you setup another test URL?


Comment 2 Jindrich Novy 2005-05-24 10:52:40 UTC
This seems to be fixed by upstream in mc-4.6.1a-0.9.


Note You need to log in before you can comment on or make changes to this bug.