Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 76670 - gettext rpm depends on libgcj
Summary: gettext rpm depends on libgcj
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: gettext
Version: 8.0
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Leon Ho
QA Contact: Jay Turner
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-10-24 19:09 UTC by Need Real Name
Modified: 2015-01-08 00:01 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Clone Of:
Environment:
Last Closed: 2002-12-16 01:18:44 UTC


Attachments (Terms of Use)

Description Need Real Name 2002-10-24 19:09:45 UTC
From Bugzilla Helper:
User-Agent: Opera/6.1 (Linux 2.4.20-pre10-ac1 i686; U)  [en]

Description of problem:
the gettext rpm (at least for i386, but i'd guess for others too) depends in libgcj.

While this is not a bug, with libgcj having a respectable size (25462079 according to rpm -qi) and surely not being used by everything that uses gettext (mostly autogen.sh and source tarballs the GNU autotools chain) I'd suggest this dependency to be removed...

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. do not install either gettext or libgcj
2. download gettext-0.11.4-3.i386.rpm
3. rpm -i gettext-0.11.4-3.i386.rpm
	

Actual Results:  rpm cmplaind about missing dependency "libgcj.so.3"

Expected Results:  gettext surely works without libgcj, too.

Additional info:

Comment 1 Leon Ho 2002-12-16 01:18:44 UTC
The library dependancy is not something that set in spec file. It automatically add it 
whatever it requires in the code. I supsect is the gettext for java require that. I don't 
think we could delete java support. 


Note You need to log in before you can comment on or make changes to this bug.