Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 76669 - A new version of bug 60042?
Summary: A new version of bug 60042?
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: pine
Version: 7.3
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Mike A. Harris
QA Contact: Ben Levenson
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-10-24 18:48 UTC by Stephen John Smoogen
Modified: 2007-04-18 16:47 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2002-10-24 18:49:28 UTC


Attachments (Terms of Use)
Complete strace -o fff1 pine sjs (deleted)
2002-10-24 18:49 UTC, Stephen John Smoogen
no flags Details

Description Stephen John Smoogen 2002-10-24 18:48:39 UTC
Description of Problem:

I am having a similar problem compared to
http://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=60042

After doing all the updates plus probably twiddling things here locally, I now
have pine crashing after doing any directory listings or trying to attach a file.

The strace will be included in next ticket.

rt_sigprocmask(SIG_BLOCK, [ALRM], [], 8) = 0
rt_sigprocmask(SIG_SETMASK, [], [ALRM], 8) = 0
write(1, "\33[4;1HCc      : \33[5;1H\33[7mAttchm"..., 69) = 69
write(1, "\33[5;11H", 7)                = 7
select(1, [0], NULL, [0], {150, 0})     = 1 (in [0], left {147, 626913})
read(0, "\24", 1)                       = 1
time(NULL)                              = 1035485281
write(1, "\33[22;1H\33[K", 10)          = 10
write(1, "\33[22;20H\33[7m[ Building file list"..., 69) = 69
stat64("/home/smoogen", {st_mode=S_IFDIR|0700, st_size=4096, ...}) = 0
open("/home/smoogen", O_RDONLY|O_NONBLOCK|O_LARGEFILE|O_DIRECTORY) = 5
fstat64(5, {st_mode=S_IFDIR|0700, st_size=4096, ...}) = 0
fcntl64(5, F_SETFD, FD_CLOEXEC)         = 0
getdents64(0x5, 0x833ea40, 0x1000, 0)   = 3272
getdents64(0x5, 0x833ea40, 0x1000, 0)   = 0
close(5)                                = 0
writev(2, [{"pine", 4}, {": ", 2}, {"relocation error", 16}, {": ", 2}, {"pine",
4}, {": ", 2}, {"undefined symbol: lstat", 23}, {"", 0}, {"", 0}, {"\n", 1}],
10) = 54
_exit(127)                              = ?



Version-Release number of selected component (if applicable):

smoogen:{smoogen}$ rpm -q pine glibc
pine-4.44-7
glibc-2.2.5-40

things that are NOT standard

kerberos -> upgraded to 1.2.6 for acluster reasons
krbafs   -> backported 8.0
cups     -> backported 8.0
Omni     -> backported 8.0
ghostscript -> ""
openssh  -> ""
pam_krb5 -> ""
webalizer -> ""

Comment 1 Stephen John Smoogen 2002-10-24 18:49:20 UTC
Created attachment 81966 [details]
Complete strace -o fff1 pine sjs

Comment 2 Mike A. Harris 2002-10-26 03:29:45 UTC
You've indicated you're using software components that are not supplied
by Red Hat, but which do link into pine.  That is not a supported
configuration for any reason.  I wont consider this a legitimate
bug report unless it can be reproduced on a clean installation
of Red Hat Linux 7.3 with all Red Hat released erratum applied, and no
externally upgraded libararies or other software which can affect
the behaviour of the application.

Closing bug NOTABUG.

Comment 3 Stephen John Smoogen 2002-10-26 15:20:24 UTC
You are absolutely correct. What caused this was a 8.0 kerberos recompiled back
to 7.3. If I had been a bit more aware when I did it, I would have looked over
the statglue patch that Nalin disabled during the changeover to 8.0. 

I am guessing that the statglue patch was added in 7.0? to fix problems between
glibc, stat64, and the kerberos libraries version. Looking through the kerberos
changelog glibc was melded to workaround this, but because of issues in kerberos
it needed to be maintained throughout the 7.x series. I missed that changelog
entry when I backcompiled the 8.0 version.

So I am thinking that anyone who opens bugs with a missing stat has probably
taken kerberos out of rawhide or something similar.

My apologies for not catching my own foolishness.



Note You need to log in before you can comment on or make changes to this bug.