Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 76666 - Hardware browser dies immediately it is launched
Summary: Hardware browser dies immediately it is launched
Keywords:
Status: CLOSED DUPLICATE of bug 74956
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: hwbrowser
Version: 8.0
Hardware: athlon
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jonathan Blandford
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-10-24 18:38 UTC by Dave Suart
Modified: 2013-04-02 04:17 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2002-10-29 21:43:03 UTC


Attachments (Terms of Use)

Description Dave Suart 2002-10-24 18:38:18 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.1) Gecko/20021003

Description of problem:
A small panel pops up saying that the collection of data may take a few minutes
followed by the browser window flashing up for a fragment of a second. 

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.By using the menu shortcut within system tools.
2.By running the command hwbrowser.
3.By reinstalling the rpm file hwbrowser*.rpm and then executing either 
command line or shortcut.
	

Actual Results:  A small panel briefly flashes up about taking a few minutes to
collect data then the hwbrowser momentarily flashes up on the screen. 

Expected Results:  The hardware browser should launch and show me my hardware. 

Additional info:

This happens only on my athlon kit on machines freshly installed or upgraded
from 7.3. All other machines freshly installed or upgraded from 7.2 are OK.

Comment 1 Dave Suart 2002-10-29 21:42:56 UTC
Output from active string as follows:-

(DeviceList.py:1693): GnomeCanvas-CRITICAL **: file gnome-canvas-path-def.c:
line 1142 (gnome_canvas_path_def_any_closed): assertion `path != NULL' failed

(DeviceList.py:1693): GnomeCanvas-CRITICAL **: file gnome-canvas-path-def.c:
line 1142 (gnome_canvas_path_def_any_closed): assertion `path != NULL' failed

(DeviceList.py:1693): GnomeCanvas-CRITICAL **: file gnome-canvas-path-def.c:
line 1142 (gnome_canvas_path_def_any_closed): assertion `path != NULL' failed

(DeviceList.py:1693): GnomeCanvas-CRITICAL **: file gnome-canvas-path-def.c:
line 1142 (gnome_canvas_path_def_any_closed): assertion `path != NULL' failed

(DeviceList.py:1693): GnomeCanvas-CRITICAL **: file gnome-canvas-path-def.c:
line 1142 (gnome_canvas_path_def_any_closed): assertion `path != NULL' failed

(DeviceList.py:1693): GnomeCanvas-CRITICAL **: file gnome-canvas-path-def.c:
line 1142 (gnome_canvas_path_def_any_closed): assertion `path != NULL' failed

(DeviceList.py:1693): GnomeCanvas-CRITICAL **: file gnome-canvas-path-def.c:
line 1142 (gnome_canvas_path_def_any_closed): assertion `path != NULL' failed

(DeviceList.py:1693): GnomeCanvas-CRITICAL **: file gnome-canvas-path-def.c:
line 1142 (gnome_canvas_path_def_any_closed): assertion `path != NULL' failed

(DeviceList.py:1693): GnomeCanvas-CRITICAL **: file gnome-canvas-path-def.c:
line 1142 (gnome_canvas_path_def_any_closed): assertion `path != NULL' failed

(DeviceList.py:1693): GnomeCanvas-CRITICAL **: file gnome-canvas-path-def.c:
line 1142 (gnome_canvas_path_def_any_closed): assertion `path != NULL' failed

(DeviceList.py:1693): GnomeCanvas-CRITICAL **: file gnome-canvas-path-def.c:
line 1142 (gnome_canvas_path_def_any_closed): assertion `path != NULL' failed
Traceback (most recent call last):
  File "/usr/share/hwbrowser/DeviceList.py", line 203, in ?
    reread_device_type_list ()
  File "/usr/share/hwbrowser/DeviceList.py", line 150, in reread_device_type_list
    list.set (iter, 0, hardware.get_category_string (key), 1, key)
  File "/usr/share/hwbrowser/DeviceList.py", line 91, in get_category_string
    return self.type_mapping[key]
KeyError: 20

Comment 2 Jonathan Blandford 2002-10-30 20:12:32 UTC

*** This bug has been marked as a duplicate of 74956 ***


Note You need to log in before you can comment on or make changes to this bug.