Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 76659 - ifdown does not release the address obtain by DHCP
Summary: ifdown does not release the address obtain by DHCP
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: initscripts
Version: 8.0
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Bill Nottingham
QA Contact: Brock Organ
URL:
Whiteboard:
: 76660 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-10-24 17:40 UTC by Christian Lepine
Modified: 2014-03-17 02:32 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2002-10-24 18:55:17 UTC


Attachments (Terms of Use)

Description Christian Lepine 2002-10-24 17:40:36 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.0)

Description of problem:
The script /sbin/ifdown or /etc/sysconfig/network-scripts/ifdown does not 
release the address obtain by DHCP.

You should add at line 79 and 82 the following :
         dhcpcd  -k  ${DEVICE}
to release the address obtain by DHCP.

With this modification the client releases the address obtain by the DHCP (when 
using dhcpcd).

Without this modification I had trouble making ddns work well.


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Configure a network card using dhcp
2.start network
3.stop network (there is no dhcp-release send by the client)
	

Actual Results:  no dhcp-release send by client

Expected Results:  dhcp-release send by client

Additional info:

Comment 1 Bill Nottingham 2002-10-24 18:55:10 UTC
*** Bug 76660 has been marked as a duplicate of this bug. ***

Comment 2 Bill Nottingham 2002-11-12 05:17:14 UTC
See 49642, it was changed to use the cache.


Note You need to log in before you can comment on or make changes to this bug.