Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 76658 - RFE:Distinguish between installed and upgraded packages during version upgrades
Summary: RFE:Distinguish between installed and upgraded packages during version upgrades
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: anaconda
Version: 8.0
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Jeremy Katz
QA Contact: Mike McLean
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-10-24 17:40 UTC by Joe Klemmer
Modified: 2007-03-27 03:58 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Clone Of:
Environment:
Last Closed: 2003-07-28 23:14:33 UTC


Attachments (Terms of Use)

Description Joe Klemmer 2002-10-24 17:40:09 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.0.1)
Gecko/20020823 Netscape/7.0

Description of problem:
When doing an upgrade from one RH version to another, if one selects to view the
packages you see a list of rpms that can either be checked or unchecked. 
Checked rpms are the ones that anaconda will upgrade to bring you to the new
version.  There is, however, no way to distinguish between packages that are not
installed and packages that are installed but not being upgraded.  It would be
good to have some indicator of what rpms are already installed but not being
upgraded.  An example would be something like this -

[X] nmap      <--- Package being installed/upgraded
[ ] iptables  <--- Package not installed
[#] snort     <--- Package currentlly installed but not needing upgrade

I hope this makes sense.  Please email me if further clarification is needed.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Start an upgrade (i.e. 7.3 to 8.0)
2. Choose to view all packages
3. You will see that any package only has two states and that there's no easy
way to tell if an unselected package is not installed or mearly not in need of
upgrading
	

Additional info:

This is something that would really be helpfull for those of us who have been
upgrading systems since RH 2.1.  :-)

Comment 1 Jeremy Katz 2003-07-28 23:14:33 UTC
This isn't a concern with our current interface.


Note You need to log in before you can comment on or make changes to this bug.