Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 76657 - modprobe cpia freezes system
Summary: modprobe cpia freezes system
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: kernel
Version: 7.2
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Arjan van de Ven
QA Contact: Brian Brock
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-10-24 16:58 UTC by Richard Moss
Modified: 2008-08-01 16:22 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2004-09-30 15:40:07 UTC


Attachments (Terms of Use)

Description Richard Moss 2002-10-24 16:58:32 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 Galeon/1.2.6 (X11; Linux i686; U;) Gecko/20020913

Description of problem:
modprobe cpia with new 2.4.18-17.xsmp kernel freezes system 100%

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.login as root
2.modprobe cpia
3.reboot,power off only option
	

Actual Results:  can't change console
no response to ctrl+alt+del


Expected Results:  module cpia loads & webcam app can be started

Additional info:

I have been starting the cpia module
at boot in rc.local and the calling webcam for 
a live parallel port camera on my webpage
my server is a pII smp dell power edge 
this has been working fine untill the newest kernel upgrade
after the upgrade and reboot the system froze before
login & after a recover boot & remoing from rc.local
it boots. I have tried modrpobe cpia after login 
and it freezes the system up 100%

Comment 1 Richard Moss 2002-10-30 16:44:26 UTC
only on smp kernel,I have tesed with non-smp and no problem
I have also gone up to 2.4.19 kernel and hard compiled in the cpia
with the same effect ..deadlock but only in smp


Comment 2 Richard Moss 2002-12-06 16:59:43 UTC
OK so..
I have compiled in (and out) the parallel port with 2.4.20
I have used the src from 1.2.2
I still get the same deadlock 
I do get messages in var now that show the modules
going in & the moment it adds in the cpia_pp
it freezes, when I just add in videodev & cpia (sans
cpia_pp)
it won't freeze (but of couse there is still no camera)
I have made a non-smp kernel and it works again
in reading postings I found a reference to the parport
driver in the kernel & made the mods to the src as well
with the same effects as before..
suggestions ? 
what should the perms in /dev be on video ?

Comment 3 Bugzilla owner 2004-09-30 15:40:07 UTC
Thanks for the bug report. However, Red Hat no longer maintains this version of
the product. Please upgrade to the latest version and open a new bug if the problem
persists.

The Fedora Legacy project (http://fedoralegacy.org/) maintains some older releases, 
and if you believe this bug is interesting to them, please report the problem in
the bug tracker at: http://bugzilla.fedora.us/



Note You need to log in before you can comment on or make changes to this bug.