Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 76655 - http kickstart doesn't work properly when booted of CD-ROM
Summary: http kickstart doesn't work properly when booted of CD-ROM
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: anaconda
Version: 8.0
Hardware: i686
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jeremy Katz
QA Contact: Mike McLean
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-10-24 16:41 UTC by Need Real Name
Modified: 2007-04-18 16:47 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2003-05-25 14:57:08 UTC


Attachments (Terms of Use)
Sample kickstart config (deleted)
2002-10-28 16:25 UTC, Need Real Name
no flags Details

Description Need Real Name 2002-10-24 16:41:35 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 Galeon/1.2.6 (X11; Linux i686; U;) Gecko/20020830

Description of problem:
I have a machine that doesn't have a floppy. Thus I decided to put a ks.cfg on a
web server and use CD-ROM 1 to boot anaconda and install. The problem I am
seeing is that even though ks.cfg has an entry that says

#Use NFS installation media
nfs --server 172.16.0.103 --dir /kickstart/RH-8.0

Actual packages are installed from the CD meaning that it prompts me for disc 2
and/or disc 3.



Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Create a ks.cfg file with NFS as the installation media
2. Use CD-ROM 1 and type

linux ks=http://172.16.0.104/ks.cfg



Actual Results:  You will see a lot of CD-ROM activity and eventually you will
be prompted for disc 2.

Expected Results:  I would expect that installation media from ks.cfg would have
been honored by anaconda.

Additional info:

Comment 1 Jeremy Katz 2002-10-24 18:53:36 UTC
Could you attach your ks.cfg (with the password line obscured obviously)?

Comment 2 Need Real Name 2002-10-28 16:25:08 UTC
Created attachment 82386 [details]
Sample kickstart config

Comment 3 Jeremy Katz 2002-10-31 20:10:44 UTC
Does the NFS location you specify work in an interactive install?  I get the
behavior you describe if the NFS directory I specify isn't the correct one.  We
probably shouldn't be falling back to the cdrom, but it looks like things work
right if I use your ks.cfg with the nfs server and directory changed.

Comment 4 Need Real Name 2002-11-04 15:15:32 UTC
NFS location works in interactive install.

Comment 5 Jeremy Katz 2002-11-08 17:58:25 UTC
Okay, added code so that we will won't automatically try the CD for kickstart,
although I can't reproduce the problem here with your kickstart config

Comment 6 Michael Fulbright 2002-12-20 17:38:25 UTC
Time tracking values updated

Comment 7 Brent Fox 2003-05-25 14:57:08 UTC
I'm going through Bugzilla closing some bugs that have been marked as Modified
for some period of time.  I believe that most of these issues have been fixed,
so I'm resolving these bugs as Rawhide.  If the bug you are seeing still exists,
please reopen this report and mark it as Reopened.


Note You need to log in before you can comment on or make changes to this bug.