Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 76640 - IBM RSS: Application 'neat' strips comments from the end of lines in modules.conf
Summary: IBM RSS: Application 'neat' strips comments from the end of lines in modules....
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: redhat-config-network
Version: 7.3
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Harald Hoyer
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks: 107565
TreeView+ depends on / blocked
 
Reported: 2002-10-24 15:00 UTC by Jeff Needle
Modified: 2007-04-18 16:47 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Clone Of:
Environment:
Last Closed: 2004-04-22 00:50:10 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2004:130 normal SHIPPED_LIVE Updated redhat-config-network package available 2004-04-21 04:00:00 UTC

Description Jeff Needle 2002-10-24 15:00:23 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 Galeon/1.2.6 (X11; Linux i686; U;) Gecko/20020913

Description of problem:
In Issues :: IBM-RSS :: Issue 9257 IBM RSS reports:

The network configuration application, neat, will strip comments from the end of
a line in modules.conf if before that comment is an entry for a loadable module.

For example, before we run neat, our modules.conf file looks like this:
alias parport_lowlevel parport_pc
# we have comments like this
alias usb-controller usb-uhci # we need end of line comments
# we have comments like this

Then after we run neat to add the ethernet adapter it looks like this:
alias parport_lowlevel parport_pc
# we have comments like this
alias usb-controller usb-uhci
# we have comments like this
alias eth0 pcnet32

We don't believe neat should be stripping any of these comments from the
modules.conf file. 

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Add comments to modules.conf
2.run neat
3.read modules.conf
	

Actual Results:  comments are missing

Expected Results:  comments are not missing

Additional info:

Comment 1 Suzanne Hillman 2003-10-03 21:03:13 UTC
Moved so it blocks, instead of depending on, the U3 blocker bug list.

Comment 2 Harald Hoyer 2003-10-06 14:36:18 UTC
built in errata-candidate

Comment 4 Suzanne Hillman 2004-04-13 20:17:37 UTC
Verified. Closing.

Comment 5 Suzanne Hillman 2004-04-13 20:18:17 UTC
*sigh* No, verified for i386. I didn't check on ia64. Putting back
into modified state.

Comment 6 John Flanagan 2004-04-22 00:50:10 UTC
An errata has been issued which should help the problem described in this bug report. 
This report is therefore being closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files, please follow the link below. You may reopen 
this bug report if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2004-130.html



Note You need to log in before you can comment on or make changes to this bug.