Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 76638 - RFE: _Always_ offer to make a boot disk
Summary: RFE: _Always_ offer to make a boot disk
Keywords:
Status: CLOSED WORKSFORME
Alias: None
Product: Red Hat Raw Hide
Classification: Retired
Component: anaconda
Version: 1.0
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Michael Fulbright
QA Contact: Mike McLean
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-10-24 14:24 UTC by R P Herrold
Modified: 2007-04-18 16:47 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2003-06-25 00:23:26 UTC


Attachments (Terms of Use)

Description R P Herrold 2002-10-24 14:24:29 UTC
In doing install and upgrades, sometimes a grub/lilo setup will fail -- I have
such a case where multiple SCSI controller drivers need to be appended to the
mkinitrd, and that is not always picked up cleanly.  Unfortunately it is often
not possible to see this until after the end of the anaconda process.

In such a case, a recovery approach is to 'upgrade' an already completely
current box.  As such, no new kernel is installed, and the flag to offer to make
a boot disk is not set.

----------------

I propose that EVERY anaconda session always default to offering the book floppy
option, even if (under current approach) it is not 'needed'.  This permits
another avenue for a clean recovery in the event of problems.

The impact of doing so to existing installs/upgrades is nil, because it is, in
such instances, asking anyway.

Comment 1 Michael Fulbright 2002-10-24 18:35:18 UTC
Unless I'm really confused I'm pretty sure we always ask the user to make a boot
floppy.

Comment 2 R P Herrold 2002-10-24 20:18:36 UTC
Nope:

1. Build a minimum RHL 7.3 box on SCSI hardware
2. Update (text) to RHL 8.0 by CD
3. Throw away the first floppy, simulating a failed floppy write
4. Using the CD, 'update' again, and it does not ask for the floppy create



Comment 3 Michael Fulbright 2002-10-30 22:43:31 UTC
Jeremy is this because we did not write out a bootloader config the second time
he did an upgrade?

Comment 4 Jeremy Katz 2002-10-31 23:30:20 UTC
I don't see any way in which we could be skipping the boot disk stage on an
upgrade, even if no kernel is being installed.  Additionally, I can't reproduce
it here (just got asked to create a boot disk on an upgraded to 8.0 -> 8.0 upgrade).

Mike, it would be reasonable to have this as one of the things we want to do
with rescue mode, though.

Comment 5 R P Herrold 2002-11-01 02:04:17 UTC
hmmm ... It was asking me in my experience -- perhaps it is sensitive to
vertion, and prior lilo.con presence -- I'll narrow down a bit and post details.

Comment 6 Bill Nottingham 2003-02-19 17:22:43 UTC
Not an enhancement, reclassifying.

Comment 7 Jeremy Katz 2003-06-25 00:23:26 UTC
I can't see anyway in our current code for this not to happen (except in the
case of not having a floppy drive, but there's not much I can do there)


Note You need to log in before you can comment on or make changes to this bug.