Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 76628 - Samba-common & Winbind directories missing
Summary: Samba-common & Winbind directories missing
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: samba
Version: 8.0
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jay Fenlason
QA Contact: David Lawrence
URL:
Whiteboard:
: 78602 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-10-24 12:05 UTC by Stephan Borg
Modified: 2014-08-31 23:24 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2004-12-02 18:22:11 UTC


Attachments (Terms of Use)

Description Stephan Borg 2002-10-24 12:05:22 UTC
Description of Problem:
I installed samba-common and samba-client RPM packages for Winbind
authentication only. After configuring the system-auth file appropriately, I
still could not log on until I created /var/log/samba and /var/run/samba
directories. I assume that these are only created in the samba-server RPM and
should probably be moved to the samba-common RPM.

Version-Release number of selected component (if applicable):
samba-common-2.2.5-10
samba-client-2.2.5-10

How Reproducible:
Without directories, log and pid files won't create and therefore not start the
winbind service.

Steps to Reproduce:
1. Modify nsswitch.conf, system-auth and smb.conf to use Winbind.
2. /etc/init.d/winbind start - will not start until directories are created.
3. wbinfo -u - should list domain users

Actual Results:
/var/log/messages shows 'Couldn not open logfile: /var/log/samba/log.winbindd'
wbinfo gives 'Error looking up domain users'

Expected Results:
No error messages in /var/log/messages
wbinfo -u - list domain users

Additional Information:

Comment 1 giulioo 2002-11-26 12:54:05 UTC
*** Bug 78602 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.