Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 76619 - static routes mess
Summary: static routes mess
Keywords:
Status: CLOSED DUPLICATE of bug 74320
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: initscripts
Version: 8.0
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Bill Nottingham
QA Contact: Brock Organ
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-10-24 10:08 UTC by Tarhon-Onu Victor
Modified: 2014-03-17 02:31 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2002-10-24 10:09:01 UTC


Attachments (Terms of Use)

Description Tarhon-Onu Victor 2002-10-24 10:08:55 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.1) Gecko/20020823
Netscape/7.0

Description of problem:
You have to device how will static routes set. Right now ifup-routes exits if it
does not find /etc/sysconfig/netrowking/devices/DEVICE.route, This is the file
which from it reads static routes parameters in some newer format.
The static routes can alsoo be defined in
/etc/sysconfig/network-scripts/route-DEVICE, acording to ifup-routes. But if we
choose to set up static routes only in
/etc/sysconfig/network-scripts/route-DEVICE, nothing will happen, because
/etc/sysconfig/networking/devices/DEVICE.route does not exist.


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.echo '10.100.100.0/23 via 10.100.102.1' >>
/etc/sysconfig/network-scripts/routes-eth8
2. ifup eth8
3. ip rou sh dev eth8 | grep 10.100.100.0


Actual Results:  The static route to 10.100.100.0/23 via gateway 10.100.102.1 is
not present into main routing table.


Additional info:

Comment 1 Bill Nottingham 2002-11-12 06:40:26 UTC

*** This bug has been marked as a duplicate of 74320 ***


Note You need to log in before you can comment on or make changes to this bug.