Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 76580 - lost audio/sound capability during kernel upgrade
Summary: lost audio/sound capability during kernel upgrade
Keywords:
Status: CLOSED DUPLICATE of bug 76171
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: kernel
Version: 8.0
Hardware: i686
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Arjan van de Ven
QA Contact: Brian Brock
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-10-23 16:43 UTC by bil kleb
Modified: 2007-04-18 16:47 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2002-10-25 04:52:56 UTC


Attachments (Terms of Use)

Description bil kleb 2002-10-23 16:43:58 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.1) Gecko/20021003

Description of problem:
After performing an up2date on my stock 8.0 kernel to go from the 2.4.18-14 to
the 2.4.18-17.8.0 kernel, I lost all audio/sound output.


Version-Release number of selected component (if applicable):
2.4.18-17.8.0


How reproducible:
Always

Steps to Reproduce:
1.Boot with new 2.4.18-17.8.0 kernel
2.Test for audio/sound [nothing]
3.Boot with old 2.4.18-14 kernel
4.Test for audio/sound [works]
	

Actual Results:  no sound/audio

Expected Results:  sound/audio

Additional info:

According to sndconfig and lspci I have a,

 ESS Technology ES1983S Maestro-3i PCI Audio Accelerator (rev10)

/etc/modules.conf has

alias sound-slot-0 maestro3
post-install sound-slot-0 /bin/aumix-minimal -f /etc/.aumixrc -L >/dev/null 2>&1
|| :
pre-remove sound-slot-0 /bin/aumix-minimal -f /etc/.aumixrc -S >/dev/null 2>&1 || :

But /var/log/messages complains about slot-1 when booting into either kernel, e.g.,

Oct 23 09:11:11 klebspc kernel: maestro3: version 1.22 built at 13:45:29 Sep  4 2002
Oct 23 09:11:11 klebspc kernel: PCI: Found IRQ 5 for device 02:03.0
Oct 23 09:11:11 klebspc kernel: maestro3: Configuring ESS Maestro3(i) found at
IO 0xEC00 IRQ 5
Oct 23 09:11:11 klebspc kernel: maestro3:  subvendor id: 0x00a31028
Oct 23 09:11:11 klebspc kernel: ac97_codec: AC97 Audio codec, id: 0x8384:0x7609
(SigmaTel STAC9721/23)
Oct 23 09:11:12 klebspc modprobe: modprobe: Can't locate module sound-service-0-0
Oct 23 09:11:12 klebspc modprobe: modprobe: Can't locate module sound-slot-1
Oct 23 09:11:12 klebspc modprobe: modprobe: Can't locate module sound-service-1-0
Oct 23 09:11:12 klebspc modprobe: modprobe: Can't locate module sound-slot-1
Oct 23 09:11:12 klebspc modprobe: modprobe: Can't locate module sound-service-1-0

I have verified my volume settings with aumix.

Comment 1 Need Real Name 2002-10-25 04:52:48 UTC
Same bug here with similar hardware. /var/log/messages: 

Oct 25 17:51:22 metropolis kernel: maestro3: version 1.23 built at 13:59:04 Oct
 8 2002
Oct 25 17:51:22 metropolis kernel: PCI: Found IRQ 5 for device 02:03.0
Oct 25 17:51:22 metropolis kernel: maestro3: Configuring ESS Maestro3(i) found
at IO 0xDC00 IRQ 5
Oct 25 17:51:22 metropolis kernel: maestro3:  subvendor id: 0x00a41028
Oct 25 17:51:22 metropolis kernel: ac97_codec: AC97 Audio codec, id:
0x1f1f:0x1f1f (Unknown)
Oct 25 17:51:23 metropolis modprobe: modprobe: Can't locate module sound-service-0-3



Comment 2 Bill Nottingham 2002-10-26 04:44:49 UTC

*** This bug has been marked as a duplicate of 76171 ***


Note You need to log in before you can comment on or make changes to this bug.