Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 7655 - root passwords over 8 characters get truncated to 8 characters
Summary: root passwords over 8 characters get truncated to 8 characters
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: installer
Version: 6.1
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Matt Wilson
QA Contact:
URL:
Whiteboard:
: 9034 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 1999-12-07 17:41 UTC by bmcgeorge
Modified: 2008-05-01 15:37 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2000-02-22 18:41:50 UTC


Attachments (Terms of Use)

Description bmcgeorge 1999-12-07 17:41:04 UTC
When doing a graphical install, root passwords over 8 characters get
truncated to 8 characters.  After install, running passwd on the root
account to change the password sets the password correctly.

Comment 1 Ken Barber 2000-01-22 12:51:59 UTC
This is caused due to the installer using 'crypt' not 'MD5' when creating the
original Shadow/Password file, even when MD5 is chosen in the installation
process.

Comment 2 Ken Barber 2000-01-22 12:53:59 UTC
Oh yeah, this is only for root. Any other accounts will be created in the
desired encryption method.

Comment 3 Bill Nottingham 2000-02-05 21:07:59 UTC
*** Bug 9034 has been marked as a duplicate of this bug. ***

Comment 4 salewis 2000-02-19 21:18:59 UTC
I have just installed RH6.1 and had a similar problem with an 8 character
password of the form q"99wert.  It would appear that using non alphanumeric
characters does not work (it did on RH5.1).  With the password of the above
style, it was possible to su in an X terminal, but not log on directly.

Comment 5 Jay Turner 2000-02-22 18:41:59 UTC
Issue has been resolved in the latest cut of the installer (available in beta)


Note You need to log in before you can comment on or make changes to this bug.