Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 76542 - Installer kernel hangs on boot
Summary: Installer kernel hangs on boot
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: kernel
Version: 8.0
Hardware: athlon
OS: Linux
Target Milestone: ---
Assignee: Arjan van de Ven
QA Contact: Brian Brock
Depends On:
TreeView+ depends on / blocked
Reported: 2002-10-23 03:38 UTC by Henry Burroughs
Modified: 2007-04-18 16:47 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Last Closed: 2003-06-05 13:35:38 UTC

Attachments (Terms of Use)
redhat 8.0 cd 1 rebuild script (deleted)
2002-11-01 18:35 UTC, Henry Burroughs
no flags Details

Description Henry Burroughs 2002-10-23 03:38:40 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.9) Gecko/20020408

Description of problem:
When I boot the install cd the kernel hangs at this message:
enabled ExtINT on CPU #0
ESR value before enabling vector: 00000002
I have to reset the system; (ctrl-alt-delete) does not work

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1. boot install cd
2. kernel hangs

Actual Results:  The kernel hangs at the above error message

Expected Results:  The kernel to finish loading

Additional info:

My system is an AMD Athlon XP 1600+ (1.4 Ghz) running on a PC CHIPS
( M825 board (via KM266 Northbridge & VT8233 Southbridge)
Matrox G400 Max, Adaptec 2940U2W SCSI card

Redhat 7.3 installs/boots properly

Comment 1 Henry Burroughs 2002-10-23 03:42:17 UTC
Whoops, I forgot to mention that I tried the 'linux noapic' , with no change in

Comment 2 Need Real Name 2002-10-24 21:04:13 UTC
Exact same problem on a PCChips M825LMR MBoard w/ Duron 13.Ghz, have tried 
following kernel parameters: noapic apm=off pci=noacpi mem=nopentium as well as 
all those mentioned on the install screen, none had any effect changing bios  
did nothing also. NB. RH7.3 works fine
I guess we got ripped buying PCChips

Comment 3 Henry Burroughs 2002-10-25 17:51:24 UTC
The problem is with "Local APIC support on uniprocessors" option under
"Processor type and features".  It is enabled on the 2.4.18-14BOOT kernel.  The
regular 2.4.18-14 kernel RPMS will install and boot on a 7.3 system. I've been
attempting to build a new bootdisk (or cdrom), and I am having limited success.
 So basically, we need a new boot.img with the Local APIC options turned off. =)
  My disk might actually work for you (I can get into the installer, but hit an
anaconda bug... it's not loading the ext3,lvm-mod, etc modules so I can't
partition) if you don't have an adaptec SCSI card that uses the aic7xxx
driver.... I think I have found info for another bug (either existing or new),
and I'm not ready to post for it yet...

FMI: I'm using the kernel-2.4.18-14BOOT.rpm and using the website: to pull apart and build a new disk.
Oh, and the kernel-***BOOT.config file in ./config under the 2.4.18-14 kernel
source directory.... and "make oldconfig" i copy the boot config file .config
and run "make oldconfig"

Comment 4 John Hall 2002-10-28 15:40:43 UTC
I am having the same problem on an ECS K7VMM (KM266 NB and VT8233 SB) with an
Athlon XP 1800+.  I have tried installing with 'linux noapic' but it still hangs
after displaying the message "ESR value before enabling vector: 00000002". 
RH7.3 installs fine, though.

Comment 5 Henry Burroughs 2002-10-28 17:57:57 UTC
Great news!! I am now running RedHat 8.0!  I have built a script to build a new
redhat 8.0 cd 1 (it automates the recompiling of the kernel, rebuilding the
image files, and making a new .iso).  I am currently cleaning it up and fixing a
few things, but otherwise it works great!!!!  I hope to have that posted within
a few days.  So a workaround now exists.

Comment 6 Henry Burroughs 2002-11-01 18:35:26 UTC
Created attachment 83064 [details]
redhat 8.0 cd 1 rebuild script

Comment 7 Henry Burroughs 2002-11-01 18:41:59 UTC
To clarify what RPMS are necessary (using rh 7.3 as a base) from the 8.0 cd:

kernel-source-2.4.18-14.i386.rpm  (cd 1)
glibc-devel-2.2.93-5.i386.rpm (cd 2)
glibc-2.2.93-5.i686.rpm (cd 2)
glibc-common-2.2.93-5.i386.rpm (cd 2)

just run "rpm -Uvh ...." where .... is all the above kernel/glibc files (you may
want to copy them all to /tmp so you can install them at once and solve the

Thanks jhall!

If you have any problems, let me know.

Comment 8 John Hall 2002-11-03 03:18:55 UTC
I can confirm that the script from burrouhb does build a working install CD that
successfully installs Red Hat Linux 8.0 on my ECS K7VMM system.  I am now
running Red Hat Linux 8.0.

Thanks burrouhb!

Comment 9 Need Real Name 2002-11-04 03:30:17 UTC
I should have written to this bug report sooner but regardless the bug is 
solved on my machine as well, thanks to's script.
Thanks to him I think this bug is now closed.

Comment 10 Alan Cox 2003-06-05 13:35:38 UTC
For RH9 we switched off the local apic support due to these sort of problems

Note You need to log in before you can comment on or make changes to this bug.