Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 76421 - Sound modules not loading properly
Summary: Sound modules not loading properly
Keywords:
Status: CLOSED DUPLICATE of bug 76171
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: kernel
Version: 8.0
Hardware: i686
OS: Linux
medium
high
Target Milestone: ---
Assignee: Arjan van de Ven
QA Contact: Brian Brock
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-10-21 16:26 UTC by Jonathon M. Robison
Modified: 2007-04-18 16:47 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2002-10-21 18:29:31 UTC


Attachments (Terms of Use)

Description Jonathon M. Robison 2002-10-21 16:26:51 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.01; Windows 98; F-5.0.1SP1-
20000718; F-5.0.1-20000221)

Description of problem:
Dell Latitude C600. Maestro3.
Normal boot: lsmod shows soundcore, maestro3, ac97_codec, but attempt to 
communicate with sound card cause kpanel to lock up, and other screen lockups. 
Tried upgrading kernel. No help. (running 2.4.18-14)

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Reboot
2.open konsole
3.playwave /usr/share/sounds/pop.wav
	

Actual Results:  kpanel becomes 100% unresponsive, no sound is played, and 
cursor doesn't come back until I use a cntrl-c on the playwave request.

Expected Results:  Should have played the wave, etc.

Additional info:

I manually removed all sound componenets vi rmmod (soundcore, maestro, 
ac97_codec.
Manually inserted with insmod in THIS ORDER:
1. soundcore
2. sound (not loaded on normal boot, and lsmod still says unused . .)
3. ac97_codec
4. maestro3

After doing it like this, sound worked. I'm not a driver writer, so I'm just 
about neck deep at this point. Can't take it any deeper for you.

/etc/modules.conf has:
alias parport_lowlevel parport_pc
alias eth0 3c59x
alias sound-slot-0 maestro
post-install sound-slot-0 /bin/aumix-minimal -f /etc/.aumixrc -L >/dev/null 
2>&1 || :
pre-remove sound-slot-0 /bin/aumix-minimal -f /etc/.aumixrc -S >/dev/null 2>&1 
|| :
alias usb-controller usb-uhci

Hope this helps. If you find a quick/easy fix, please tell me? I don't really 
want to add all this to rc.local

Comment 1 Elliot Peele 2002-10-21 18:12:37 UTC
This looks like a dup of 76148

Comment 2 Jonathon M. Robison 2002-10-21 18:29:22 UTC
After reviewing 76148, I tend to agree that they are likely the same problem. 
However, I had not found out about the killing of esd.
BTW - compiling your own 2.4.18-17.8.0-custom doesn't help.

Comment 3 Bill Nottingham 2002-10-26 04:45:45 UTC

*** This bug has been marked as a duplicate of 76171 ***


Note You need to log in before you can comment on or make changes to this bug.