Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 7641 - login does not recognize pts/0 ... in securetty
Summary: login does not recognize pts/0 ... in securetty
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: util-linux
Version: 6.1
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Crutcher Dunnavant
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 1999-12-06 22:29 UTC by dlm
Modified: 2008-05-01 15:37 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2000-02-04 00:07:01 UTC


Attachments (Terms of Use)

Description dlm 1999-12-06 22:29:20 UTC
There does not appear to be any string which can be used in securetty which
will allow network root logins as documented.  In previous versions, ttyp1,
... worked.  In 6.1 (and 6.0 I think) a logged-in user shows, e.g., pts/1,
but using that string in securetty still does not permit a root login.

Removing securetty entirely does allow root login as documented.  This
indicates that the problem is in fact in the interpretation of the file.

Comment 1 Elliot Lee 2000-02-04 00:07:59 UTC
I've tried to fix this in pam-0.72-4 - a workaround in the meantime is to put
just the plain tty number (without the 'pts/' prefix) into /etc/securetty.

Putting anything other than local ttys in securetty is meaningless though,
because there is no guarantee that a particular individual or source host will
be assigned to a pty. The possibility is very real for anyone to deny you root
access, or alternatively gain root access themself. You'd at least avoid the DoS
attack by turning off securetty altogether.


Note You need to log in before you can comment on or make changes to this bug.