Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 76373 - kdeinit hangs and causes other programs to crash
Summary: kdeinit hangs and causes other programs to crash
Keywords:
Status: CLOSED DUPLICATE of bug 80664
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: kdelibs
Version: 8.0
Hardware: i386
OS: Linux
medium
high
Target Milestone: ---
Assignee: Ngo Than
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-10-21 02:00 UTC by Nathan G. Grennan
Modified: 2007-04-18 16:47 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2006-02-21 18:50:00 UTC


Attachments (Terms of Use)

Description Nathan G. Grennan 2002-10-21 02:00:25 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 Galeon/1.2.6 (X11; Linux i686; U;) Gecko/20021017

Description of problem:
I run all my common applications on the start of X. Terminal Windows, Web
Browser, E-mail Client, etc. I do this via a shell script called by Gnome2's
manual startup option. If I tell it to run 4 konsole and konqueror, kdeinit
barfs on startup everytime. Depending on if they are in memory or not sometimes
Konqueror will start, sometimes one or more terminals will start, but I will get
at least one crash dialog. If I look with ps ax I see alot of kdeinit --suicide
and such sitting around. If I killall kdeinit and then try to start 4 konsoles
at once it works just fine. It seems to be isolated to either starting konqueror
and a konsole fairly close together, or something about the load of starting
some many applications at once. 

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Setup startup script that starts alot of programs including Konqueror and
Konsole with Gnome2
2. Start X

	

Actual Results:  Crash dialogs

Expected Results:  Applications to start normally

Additional info:

I also see this problem with the newer kdelibs 3.0.4-2 from rawhide.

startup:

#!/bin/bash

evolution --no-splash &
galeon &
gaim &
sleep 10
xchat &
xmms &
sleep 10
kfmclient openProfile filemanagement &
terms &


terms:

#!/bin/bash

konsole -T Terminal1 &
sleep 2
konsole -T Terminal2 &
sleep 2
konsole -T Terminal3 &
sleep 2
konsole -T Terminal4 &

Comment 1 Ngo Than 2002-12-22 12:49:28 UTC
Hmm, i have tested on 2 local machines. it works for me. 

Comment 2 Nathan G. Grennan 2002-12-23 07:11:51 UTC
I just tried this again and got the four terminals, but not konqueror.

Comment 3 Mike A. Harris 2003-01-02 09:52:40 UTC
What speed CPU, and how much RAM?  Could be a race condition that perhaps
doesn't trigger on some hardware..

Comment 4 Nathan G. Grennan 2003-01-02 09:59:49 UTC
CPU 1.47ghz(Athlon XP 1700+) with 512mb of memory

I have also seen it with the same processor in another motherboard with 768mb of
memory.

When I use konsole as my terminal program I have to not put the terminals in the
startup, wait for konqueror to completely load, and then load the terminals.

Comment 5 Miloslav Trmac 2003-01-13 12:28:13 UTC
Note also bug 80664. Seems similar and contains some possibly useful
info.

Comment 6 Nathan G. Grennan 2003-01-15 12:35:28 UTC
I have gotten rid of this by starting my home directory out fresh. I know the
bug is still lurking out there, but I am not no longer able to reproduce it with
KDE 3.1 in rawhide and the clean home directory.

Comment 7 Nathan G. Grennan 2003-01-20 17:12:15 UTC
Just finished rebooting after upgrading my kernel to 2.4.20-2.22 and this
problem is Back! I am running phoebe2 now.

Comment 8 Nathan G. Grennan 2003-01-21 16:05:27 UTC
Still running phoebe2, but have downgraded my kernel to 2.4.18-19.8.0 and the
problems happens everytime. So has something to do with the kernel, maybe nptl
helps.

Comment 9 Ngo Than 2004-07-19 11:08:28 UTC

*** This bug has been marked as a duplicate of 80664 ***

Comment 10 Red Hat Bugzilla 2006-02-21 18:50:00 UTC
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.


Note You need to log in before you can comment on or make changes to this bug.