Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 76313 - if timezone isn't in timezone list, redhat-config-date tracebacks
Summary: if timezone isn't in timezone list, redhat-config-date tracebacks
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: redhat-config-date
Version: 8.0
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Brent Fox
QA Contact:
URL:
Whiteboard:
: 74206 76164 76707 77254 77436 78786 79400 79699 80058 80431 80432 82721 82829 83353 83469 84071 85112 98092 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-10-19 19:25 UTC by Jeremy Katz
Modified: 2008-05-01 15:38 UTC (History)
9 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2002-10-19 19:25:55 UTC


Attachments (Terms of Use)

Description Jeremy Katz 2002-10-19 19:25:47 UTC
If the current timezone isn't in the zone.tab list (ie, it's something like
'UTC'), then redhat-config-date will traceback in timezone_map_gui.py
setCurrent() with currentEntry being None.  Something like the following looks
like the right patch

Index: timezone_map_gui.py
===================================================================
RCS file: /usr/local/CVS/redhat-config-date/src/timezone_map_gui.py,v
retrieving revision 1.11
diff -u -u -r1.11 timezone_map_gui.py
--- timezone_map_gui.py 21 Aug 2002 23:08:35 -0000      1.11
+++ timezone_map_gui.py 19 Oct 2002 19:20:19 -0000
@@ -174,9 +174,10 @@
         if not entry:
             # If the value in /etc/sysconfig/clock is invalid, default to New York
             self.currentEntry = self.fallbackEntry
+        else:
+            self.currentEntry = entry

         self.markers[self.currentEntry.tz].show()
-        self.currentEntry = entry
         self.markers[self.currentEntry.tz].hide()
         x, y = self.map2canvas(self.currentEntry.lat, self.currentEntry.long)
         self.current.set(x=x, y=y)

Comment 1 Brent Fox 2002-10-22 15:22:04 UTC
Patch applied in cvs.  The fix should appear in redhat-config-date-1.5.3-1. 
Thanks for the patch.

Comment 2 Brent Fox 2002-10-22 15:59:54 UTC
*** Bug 76164 has been marked as a duplicate of this bug. ***

Comment 3 Brent Fox 2002-10-22 16:05:24 UTC
*** Bug 74206 has been marked as a duplicate of this bug. ***

Comment 4 Brent Fox 2002-10-25 13:34:28 UTC
*** Bug 76707 has been marked as a duplicate of this bug. ***

Comment 5 Brent Fox 2002-11-04 16:08:33 UTC
*** Bug 77254 has been marked as a duplicate of this bug. ***

Comment 6 Brent Fox 2002-11-07 15:52:52 UTC
*** Bug 77436 has been marked as a duplicate of this bug. ***

Comment 7 Brent Fox 2002-12-11 14:51:05 UTC
*** Bug 79400 has been marked as a duplicate of this bug. ***

Comment 8 Brent Fox 2002-12-11 16:52:07 UTC
*** Bug 78786 has been marked as a duplicate of this bug. ***

Comment 9 Brent Fox 2002-12-17 17:11:52 UTC
*** Bug 79699 has been marked as a duplicate of this bug. ***

Comment 10 Brent Fox 2002-12-19 14:58:20 UTC
*** Bug 80058 has been marked as a duplicate of this bug. ***

Comment 11 Brent Fox 2002-12-26 16:25:29 UTC
*** Bug 80432 has been marked as a duplicate of this bug. ***

Comment 12 Brent Fox 2002-12-26 16:26:29 UTC
*** Bug 80431 has been marked as a duplicate of this bug. ***

Comment 13 Brent Fox 2003-01-27 19:38:08 UTC
*** Bug 82829 has been marked as a duplicate of this bug. ***

Comment 14 Brent Fox 2003-02-04 20:24:37 UTC
*** Bug 83469 has been marked as a duplicate of this bug. ***

Comment 15 James Beale 2003-02-05 21:08:26 UTC
After reading this (76313) I hope this further information will be of use to 
someone, but try by checking the "clock" file in âetc/sysconfigâ first.

Mine looked like:

ZONE="Etc/GMT"
UTC=true
ARC=false

But the ZONE statement should have been:

ZONE="Europe/London"

Comment 16 Brent Fox 2003-02-05 21:55:31 UTC
*** Bug 83353 has been marked as a duplicate of this bug. ***

Comment 17 Brent Fox 2003-02-06 02:24:16 UTC
*** Bug 83353 has been marked as a duplicate of this bug. ***

Comment 18 Brent Fox 2003-02-06 19:25:49 UTC
*** Bug 83353 has been marked as a duplicate of this bug. ***

Comment 19 Brent Fox 2003-02-11 21:47:16 UTC
*** Bug 84071 has been marked as a duplicate of this bug. ***

Comment 20 Brent Fox 2003-02-25 21:57:38 UTC
*** Bug 85112 has been marked as a duplicate of this bug. ***

Comment 21 Brent Fox 2003-04-01 17:40:32 UTC
*** Bug 82721 has been marked as a duplicate of this bug. ***

Comment 22 Brent Fox 2003-06-26 15:22:09 UTC
*** Bug 98092 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.