Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 7626 - RH 6.1 smbmount not working ! smbclient works fine!
Summary: RH 6.1 smbmount not working ! smbclient works fine!
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: kernel
Version: 6.1
Hardware: sparc
OS: Linux
high
high
Target Milestone: ---
Assignee: Michael K. Johnson
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 1999-12-06 10:52 UTC by Schalk Klee
Modified: 2008-05-01 15:37 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2000-02-05 21:38:57 UTC


Attachments (Terms of Use)
patch to 2.2.14 kernel to fix smbmount on sparc64 (deleted)
2000-01-18 16:40 UTC, Bill Nottingham
no flags Details | Diff

Description Schalk Klee 1999-12-06 10:52:17 UTC
I cannot get RH6.1 on a UltraSparc 1 to mount any SMB resources.  When I
tried to mount a resource I get "mount Error: Bad Address".

Here are the details:
## Hosts File ##
127.0.0.1       localhost       localhost.localdomain localhost
192.6.2.27      ghost           ghost.rubico.com
192.6.2.1       alice           alice.rubico.com
192.6.2.4       janice          janice.rubico.com
192.6.2.27      spectre         spectre.rubico.com
192.6.2.27      wnt-sklee       wnt-sklee.rubico.com

## SMB.CONF ###

[global]
   workgroup = rubico.com
   server string = Intranet/Internet Server
   load printers = yes
   log file = /usr/local/samba/var/log.%m
   max log size = 50
   security = user
   socket options = TCP_NODELAY
   interfaces = 192.6.2.7/255.255.255.0
   dns proxy = no
[homes]
   comment = Home Directories
   browseable = no
   writable = yes
[printers]
   comment = All Printers
   path = /usr/spool/samba
   browseable = no
   guest ok = no
   writable = no
   printable = yes
[tmp]
   comment = Temporary file space
   path = /tmp
   read only = no
   public = yes

### smbmount command & result ###

variations of command that I have tried :
smbmount //alice/rubico /mnt/smb
smbmount //ALICE/RUBICO /mnt/smb
smbmount '\\alice\rubico' /mnt/smb
smbmount '\\ALICE\RUBICO' mnt/smb
smbmount \\\\alice\\rubico /mnt/smb
smbmnt /mnt/smb -s //alice/rubico
smbmnt /mnt/smb -s \\\\alice\\rubico
smbmnt /mnt/smb -s '\\alice\rubico
etc ..

all result in the following:
[root@ghost /root]# smbmount '\\ALICE\RUBICO' /mnt/smb
mount error: Bad address
Please refer to the smbmnt(8) manual page
Added interface ip=192.6.2.7 bcast=192.6.2.255 nmask=255.255.255.0
mount failed
Added interface ip=192.6.2.7 bcast=192.6.2.255 nmask=255.255.255.0

## With Debug ##

[root@ghost /root]# smbmount '\\ALICE\RUBICO' /mnt/smb -d 3
smbmount started (version 2.0.5a)
Initialising global parameters
params.c:pm_process() - Processing configuration file "/etc/smb.conf"
Processing section "[global]"
doing parameter workgroup = rubico.com
doing parameter server string = Intranet/Internet Server
doing parameter load printers = yes
doing parameter log file = /usr/local/samba/var/log.%m
doing parameter max log size = 50
doing parameter security = user
doing parameter socket options = TCP_NODELAY
doing parameter interfaces = 192.6.2.7/255.255.255.0
doing parameter dns proxy = no
pm_process() returned Yes
Added interface ip=192.6.2.7 bcast=192.6.2.255 nmask=255.255.255.0
mount error: Bad address
Please refer to the smbmnt(8) manual page
mount failed

Comment 1 Bill Nottingham 1999-12-06 17:15:59 UTC
Do a 'umount /mnt/smb', and then try. Does the error change
at all?

If smbmount fails, it can leave the target directory in
a 'half-mounted' state, that needs to be umounted before
you can use the directory again.

Comment 2 Schalk Klee 1999-12-07 07:56:59 UTC
The umount makes no difference at all.
Why does it report the bad address error even before it starts Samba?

TIA
Schalk

Comment 3 Bill Nottingham 1999-12-08 23:13:59 UTC
Because it's broken. Confirmed; broken on sparc64, works on sparc32.

Currently investigating as to why it's broken.

Comment 4 Schalk Klee 1999-12-29 14:21:59 UTC
Any progress on this ?

Comment 5 Bill Nottingham 1999-12-30 17:57:59 UTC
Sorry about the delay.

It's a kernel bug, it should be fixed in 2.2.14 final.

Comment 6 Schalk Klee 2000-01-06 12:54:59 UTC
Any results yet ?  I see 2.2.14 was released a couple of days ago.  When can we
expect the new kernel in RPM format ?

Comment 7 Bill Nottingham 2000-01-06 16:22:59 UTC
A 2.2.14 kernel will be in the next Raw Hide release, should
be today sometime.

Comment 8 Schalk Klee 2000-01-13 16:33:59 UTC
I installed the 2.2.14 kernel off the rawhide.redhat.com site.

Bad news:  It did not solve the problem!

It did change the error message though.  The error message now is :

sys32_ioctl: unknown cmd fd(4) cmd(802c7502) arg(effe300)
mount.smbfs: ioctl failed, res=-1

I checked with uname -a  that the kernel version is 2.2.14-1.1.0. Smbclient to
the same smb share still works fine. It now als fails to unmount the mount point
which means you must run the umount command before you can run smbmount again.

Also got the latest version of samba (2.06a) of the server.  That made no
difference to the problem.

PLEASE HELP!

Comment 9 Bill Nottingham 2000-01-18 16:40:59 UTC
Created attachment 63 [details]
patch to 2.2.14 kernel to fix smbmount on sparc64

Comment 10 Bill Nottingham 2000-02-05 21:38:59 UTC
Fixed in 2.2.15pre kernels; a version of this will be in the next
Raw Hide release.


Note You need to log in before you can comment on or make changes to this bug.