Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 76164 - redhat-config-date crash
Summary: redhat-config-date crash
Keywords:
Status: CLOSED DUPLICATE of bug 76313
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: redhat-config-date
Version: 8.0
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Brent Fox
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-10-17 18:46 UTC by Martin Garton
Modified: 2008-05-01 15:38 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2002-10-17 18:48:31 UTC


Attachments (Terms of Use)
this is a fix. (NB _a_ fix, not neccesarily _the_ fix as I haven't spent long understanding the current code) (deleted)
2002-10-17 18:48 UTC, Martin Garton
no flags Details | Diff

Description Martin Garton 2002-10-17 18:46:42 UTC
Description of Problem:
Can't use redhat-config-date at all. Selecting from menu results in no apparent
action.

Steps to Reproduce:
1. Install redhat linux 8.0
2. when prompted select (for example) UTC+1 as the timezone
3. after firstboot etc, select systemsettings->date&time from the gnome menu

Actual Results:
Nothing


Expected Results:
Date and time utility should open


Additional Information:
running from a terminal reveals the problem:

Traceback (most recent call last):
  File "/usr/share/redhat-config-date/redhat-config-date.py", line 35, in ?
    mainWindow.mainWindow().stand_alone()
  File "/usr/share/redhat-config-date/mainWindow.py", line 181, in __init__
    self.timezonePage = timezone_gui.timezonePage()
  File "/usr/share/redhat-config-date/timezone_gui.py", line 50, in __init__
    self.tz = TimezoneMap(zonetab, self.default, map=path)
  File "/usr/share/redhat-config-date/timezone_map_gui.py", line 139, in __init__
    self.setCurrent(self.currentEntry)
  File "/usr/share/redhat-config-date/timezone_map_gui.py", line 180, in setCurrent
    self.markers[self.currentEntry.tz].hide()
AttributeError: 'NoneType' object has no attribute 'tz'


Furthermore, /etc/sysconfig/clock contains:

ZONE="Etc/GMT+1"
UTC=true
ARC=false

and "Etc/GMT+1" does not appear in /usr/share/zoneinfo/zone.tab which causes the
problem.

The code in /usr/share/redhat-config-date/timezone_map_gui.py already looks like
its trying to handle this, but it doesn't work.

Comment 1 Martin Garton 2002-10-17 18:48:25 UTC
Created attachment 80824 [details]
this is a fix. (NB _a_ fix, not neccesarily _the_ fix as I haven't spent long understanding the current code)

Comment 2 Brent Fox 2002-10-22 16:00:00 UTC

*** This bug has been marked as a duplicate of 76313 ***


Note You need to log in before you can comment on or make changes to this bug.